subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Corveleyn <jcor...@gmail.com>
Subject Re: Error assertion during update
Date Sun, 16 Jun 2013 19:24:05 GMT
On Thu, Jun 13, 2013 at 3:54 PM, פאנל תוכנה - ניר בר
<nir.bar@panel-sw.co.il> wrote:
> Hi,
> I encountered this error while updating from windows explorer.
> I discovered that someone committed to the repository a folder called "E:"
> After removing that folder from the repository the error didn't re-occur
>
> Nir
>
>
>
>
> ---------------------------
> Subversion Exception!
> ---------------------------
> Subversion encountered a serious problem.
> Please take the time to report this on the Subversion mailing list
> with as much information as possible about what
> you were trying to do.
> But please first search the mailing list archives for the error message
> to avoid reporting the same problem repeatedly.
> You can find the mailing list archives at
> http://subversion.apache.org/mailing-lists.html
>
> Subversion reported the following
> (you can copy the content of this dialog
> to the clipboard using Ctrl-C):
>
> In file
>
> 'D:\Development\SVN\Releases\TortoiseSVN-1.7.12\ext\subversion\subversion\libsvn_wc\update_editor.c'
>  line 1587: assertion failed (action == svn_wc_conflict_action_edit ||
> action
>  == svn_wc_conflict_action_delete || action ==
> svn_wc_conflict_action_replace)
> ---------------------------
> ---------------------------
>

Hi Nir,

Thanks for the report. I believe this crash is specific to TortoiseSVN
(so maybe you can also report it on the Tortoise mailinglist [1]).
More specifically, with the commandline I also get strange behavior,
but not a crash:

1) When I try this with commandline 1.7.9, I get some strange behavior
that notifies an "Exists" notification (E), but doesn't really
checkout the directory. See below [2]. This is obviously a bug, but it
doesn't crash. It seems this is very much like this issue:
http://subversion.tigris.org/issues/show_bug.cgi?id=3288 (svn crashes
when checking out subdirectories with backslashes in their names),
which is fixed in 1.8.0, but see below.

2) When I try this with commandline 1.8.0 (to be released in a couple
of days), I get a nice error, but the output isn't exactly right. It
says:

[[[
C:\Temp\svntest18>svn --version -q
1.8.0

C:\Temp\svntest18>svnadmin create repos

C:\Temp\svntest18>svn co file:///c:/temp/svntest18/repos wc
Checked out revision 0.

C:\Temp\svntest18>svn mkdir -mm "file:///c:/temp/svntest18/repos/E:"

Committed revision 1.

C:\Temp\svntest18>svn up wc
Updating 'wc':
svn: E155000: '.' is not valid as filename in directory 'C:\Temp\svntest18\wc'
]]]

So instead of 'E:' it says '.'. But it's already much better than 1.7.
I'll check if I can find out why it doesn't report the correct invalid
filename.

[1] http://tortoisesvn.net/community.html

[2] With 1.7.9 I get the following:

[[[
C:\Temp\svntest>svnadmin create repos

C:\Temp\svntest>svn co file:///c:/temp/svntest/repos wc
Checked out revision 0.

C:\Temp\svntest>cd wc

C:\Temp\svntest\wc>cd ..

C:\Temp\svntest>svn mkdir -mm "file:///c:/temp/svntest/repos/E:"

Committed revision 1.

C:\Temp\svntest>svn ls file:///c:/temp/svntest/repos
E:/

C:\Temp\svntest>svn up wc
Updating 'wc':
E    wc
Updated to revision 1.

C:\Temp\svntest>cd wc

C:\Temp\svntest\wc>dir
 Volume in drive C has no label.
 Volume Serial Number is 00C1-25E4

 Directory of C:\Temp\svntest\wc

06/16/2013  08:38 PM    <DIR>          .
06/16/2013  08:38 PM    <DIR>          ..
               0 File(s)              0 bytes
               2 Dir(s)  32,266,878,976 bytes free

]]]

--
Johan

Mime
View raw message