subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthijs Kooijman <matth...@stdin.nl>
Subject make clean-swig-pl breaking the build (possible fix included)
Date Tue, 18 Jun 2013 16:31:42 GMT
(I'm not subscribed to the list, so please keep me CC'd)

Hi folks,

I'm having a bit of trouble with a local build of 1.8.0-rc3 and the perl
bindings. Initially, everything was ok, but I think things stopped
working after I ran "make clean-swig-pl": Only _Core.so is generated
and installed now, but no _Delta.so, _Wc.so, etc.

I think I see what happens: subversion/bindings/swig/perl/native/Makefile
contains:

	modules :: svn_client.c svn_delta.c svn_fs.c svn_ra.c svn_repos.c svn_wc.c
		$(MAKE) -f Makefile.client
		$(MAKE) -f Makefile.delta
		$(MAKE) -f Makefile.fs
		$(MAKE) -f Makefile.ra
		$(MAKE) -f Makefile.repos
		$(MAKE) -f Makefile.wc
		$(NOECHO) $(TOUCH) $@

This is ran whenever "make swig-pl" is ran from the root directory. Note the
touch at the end: This creates a file called "modules" to track the fact
that the modules have been built.

However, when "make clean-swig-pl" is ran, the modules built are
removed, but the "modules" file is left in place, letting make think
nothing needs to be built, causing a broken install.

Manually removing the "modules" file fixes the build for me, I assume
that removing it from the clean target in
subversion/bindings/swig/perl/native/Makefile would also work (though I
didn't test this explicitely).

After this, if I run "make clean-swig-pl", the build breaks again as
before, making me confident this analysis is correct.

Gr.

Matthijs

Mime
View raw message