subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: Help with compiling
Date Sun, 07 Apr 2013 13:17:57 GMT
Maureen Barger wrote on Sat, Apr 06, 2013 at 12:35:59 -0400:
> On Sat, Apr 6, 2013 at 12:31 PM, Daniel Shahaf <d.s@daniel.shahaf.name> wrote:
> > Is AP_HAVE_C99 defined?
> How do I check?
> 

You could look for a '#define AP_HAVE_C99 1' line in files that
http_log.h includes.

> > Did svn's build use the right copy of http_log.h?
> How do I check?
> 

For starters, run 'locate http_log.h'.

Maybe there's a --verbose $CC flag that'll give the information you
need, but I'd just throw an #error directive into the one you installed
--- namely, /etc/apache2/include/**/http_log.h --- and confirm that
'make mod_dav_svn' in Subversion's source tree now errors.

That is,
echo '#error "foo"' >> /etc/apache2/include/**/http_log.h

> >
> >
> >> I installed all required libraries using the autogen.sh script
> >> I placed the apr and apr-util within the src of apache.
> >>
> >> I built apache first.
> >> ./configure --enable-dav --enable-so --enable-ssl
> >> --prefix=/etc/apache2 --with-included-apr --with-included-apr-util
> >> --enable-dav-fs --enable-dav-lock
> >>
> >> Then I built svn.
> >> ./configure --with-apr=/etc/apache2 --with-apr-util=/etc/apache2
> >> --with-serf=/usr/local/serf --with-httpd
> >> --with-apxs=/etc/apache2/bin/apxs
> >> --with-apache-libexecdir=/etc/apache2/modules
> >>
> >> What am I missing?
> >> Thanks.

Mime
View raw message