subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Shahaf <...@daniel.shahaf.name>
Subject Re: svnserve crash
Date Fri, 02 Nov 2012 18:35:11 GMT
Please attach log files as text/* MIME type (maybe by renaming them to
*.txt) so it's easier to read/reply to them.

Now, the first thing that jumps out is that some of the actual
parameters are 0x00000000 or 0x00001000; for example:

#14  0x13f639fd8 in serve(conn=(svn_ra_svn_conn_st *) 0x00000000, params=(serve_params_t *)
0x00000000, pool=(apr_pool_t *) 0x00000000) at

which might suggest a stack smash, or just that this is how windows
stack traces normally work and I'm not aware of that convention.

Are you using 1.7.7?


Mark Raymond wrote on Thu, Nov 01, 2012 at 21:21:21 -0000:
> Background:
> 
> A week or so ago, I tried to set up svnserve with sasl authentication
> (DIGEST-MD5 & sasldb), which I tried using various binaries of subversion (I
> tried TortoiseSVN, CollabNet and Wandisco), to no avail (if you want more
> details, see my email on 20/10/2012; basically authentication kept failing
> despite credentials being correct). As I had to create the sasldb on Linux
> due to a lack of Windows binaries of saslpasswd2, I thought that might be
> the problem, so I set about compiling everything from source, which I have
> now done. My binaries appear to work, generally; in particular, svnserve
> works fine when using inbuilt authentication without sasl.
> 
> Problem:
> 
> I have svnserve running, using sasl, sasl being set up to use DIGEST-MD5 and
> sasldb. When I try to check out the repository, svnserve crashes, producing
> the attached log and dump files. The configuration files are good (they work
> on Xubuntu, using a  sasldb created on Xubuntu with the same parameters I
> used on Windows)
> 
> Does anyone know what could be the problem causing the crash?
> 
> Thanks!




Mime
View raw message