subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Заболотный Андрей <zappare...@yandex.ru>
Subject Renaming UTF-8 file names is broken
Date Thu, 15 Nov 2012 10:50:20 GMT
Hello!

I've got an issue here. We have a lot of file names in repository using UTF-8 characters.
All worked well till I decided to do move one of these files to another directory.

The 'svn move' command worked fine. But when I tried to commit the transaction, that's what
I've got:

Adding         doc/forth-asm/Карта памяти.txt
svn: E155011: Commit failed (details follow):
svn: E155011: File '/home/zap/projects/СУ АКБ/doc/forth-asm/Карта памяти.txt'
is out of date
svn: E160013: File not found: transaction '12-m', path '/%D0%A1%D0%A3%20%D0%90%D0%9A%D0%91/doc/forth-asm/%D0%9A%D0%B0%D1%80%D1%82%D0%B0%20%D0%BF%D0%B0%D0%BC%D1%8F%D1%82%D0%B8.txt'
svn: E155011: Your commit message was left in a temporary file:
svn: E155011:    '/home/zap/projects/svn-commit.tmp'

It looks like it tries to access the file with the wrong filename containing all those %D0
etc, and naturally fails.

Can this be worked around somehow, or it's a dead end?

-- 
Andrew

Mime
View raw message