subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "L'oiseau2nuit" <l.oiseau2n...@gmail.com>
Subject Re: Problem running on simple svn commands on CentOs
Date Fri, 10 Aug 2012 07:16:38 GMT
Thanks for helping :-)


> svn --version
>

Currently indicates 1.7.5

[root@host]# svn --version
svn, version 1.7.5 (r1336830)
   compiled Aug  9 2012, 18:21:35

Copyright (C) 2012 The Apache Software Foundation.
This software consists of contributions made by many people; see the NOTICE
file for more information.
Subversion is open source software, see http://subversion.apache.org/

The following repository access (RA) modules are available:

* ra_svn : Module for accessing a repository using the svn network protocol.
  - with Cyrus SASL authentication
  - handles 'svn' scheme
* ra_local : Module for accessing a repository on local disk.
  - handles 'file' scheme


This would mean all my rollback attempts were useless anyway... hmmm...




> svn help upgrade
>

upgrade: Upgrade the metadata storage format for a working copy.
usage: upgrade [WCPATH...]

  Local modifications are preserved.

Valid options:
  -q [--quiet]             : print nothing, or only summary information

Global options:
  --username ARG           : specify a username ARG
  --password ARG           : specify a password ARG
  --no-auth-cache          : do not cache authentication tokens
  --non-interactive        : do no interactive prompting
  --trust-server-cert      : accept SSL server certificates from unknown
                             certificate authorities without prompting (but
only
                             with '--non-interactive')
  --config-dir ARG         : read user configuration files from directory
ARG
  --config-option ARG      : set user configuration option in the format:
                                 FILE:SECTION:OPTION=[VALUE]
                             For example:
                                 servers:global:http-library=serf


So what I do not understand is why when attempting to upgrade my working
copies, it says "upgrade command not found" ... oO


It seems to work a bit better today ! I managed to 'svn up' all my working
copies but still two of them are missing (not checked out by my script) and
still, when trying to check them out :

svn checkout svn://
zone.spip.org/spip-zone/_plugins_/champs_extras/core/trunk/champs_extras_core

i got the following message :

svn: E155036: Please see the 'svn upgrade' command
svn: E155036: Working copy '/champs_extras_core' is too old (format 10,
created by Subversion 1.6)

For the two of them. Weird isn't it ?

When I try 'svn upgrade' it returns :

[root@host _trunk]# svn upgrade
svn: E155019: Can't upgrade
'/var/www/vhosts/****.*****************.**/httpdocs/spip/plugins/_api-dist/_trunk'
as it is not a pre-1.7 working copy directory
svn: E000002: Can't open file
'/var/www/vhosts/****.*****************.**/httpdocs/spip/plugins/_api-dist/_trunk/.svn/entries':
No such file or directory

There's a thin line between me and the solution but ... :-/

Anyway, thanks again for the help ;)



-- 
*Etienne.****
<http://www.musique2nuit.fr/>*

Mime
View raw message