subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vishwajeet singh <dextrou...@gmail.com>
Subject Re: Problem running on simple svn commands on CentOs
Date Thu, 09 Aug 2012 18:32:37 GMT
On Thu, Aug 9, 2012 at 11:42 PM, L'oiseau2nuit <l.oiseau2nuit@gmail.com>wrote:

>
> Hi there,
>
> I'm driving crazy, trying to have SVN work properly on my CentOS server
> (CentOS release 5.6 Final)
>
>
> When installing subversion from the official CentOS repositories, I'm
> getting version 1.6.11 with its mod_dav_svn.
> Everything's ok 'till this point.
>
> I then browse to my website's root directory and execute a shell script
> which usually checked out and organize some source codes I wish to install.
> (basically, I want to checkout out a whole CMS + some of its plugins, with
> some mkdir and cd's directives to checkout the different source codes and
> put them in the directories they have to be in)
>
> The sh seems to execute quite well but 2 errors appear with no relevant
> reason, when try to checkout 2 of my CMSs plugins  :
>
> svn: E155036: Please see the 'svn upgrade' command
> svn: E155036: Working copy '/name_of_target_folder' is too old (format 10,
> created by Subversion 1.6)
>
> Seems that all my other instructions has been pretty executed, so I browse
> to the target folder's parent directory, in which I first wanted to deploy
> that so called "too old working copy" and then try to make a manual "svn
> checkout" which results in ... Same error !
>
> I then decide to try the 'svn upgrade' command, as suggested, which
> results in : "upgrade" unknown command, ???? Ô_Ô
>
>
>
> Then, tried to remove subversion 1.6.11 and got the source for the 1.7.5
> version, which I did ./configure - make - make install and everything...
>
> Second run with my shell :
>
> * still the same errors on the same plugins
> * no further "svn checkout" or "svn update" allowed without an "seems to
> be part of subversion 1.7 or greater..." error
> * svn upgrade still not working.
>
>
> Sorry but I just touched the limit between my skills and the real life.
>
> Can anyone help me with this issue please ?
>

Can you please run few commands and share output with us ?

svn --version
svn help upgrade


>
> thanks in advance for your answers (and by the way, forgive my english.
> I'm French and did not practice your language for years ^^)
>
>
>
> --
> *Etienne.****
> <http://www.musique2nuit.fr/>*
>



-- 
Vishwajeet Singh
+91-9657702154 | dextrous85@gmail.com | http://bootstraptoday.com
Twitter: http://twitter.com/vishwajeets | LinkedIn:
http://www.linkedin.com/in/singhvishwajeet

Mime
View raw message