subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Fodrek <peter.fod...@stuba.sk>
Subject Subversion 1.6.16 SASL, LDAP problem to determine problem source(fodrek)
Date Wed, 04 Apr 2012 15:49:12 GMT
Dear SVN experts,


I would like to ask, how to setup subversion  to work with sasl and LDAP 
(LDAP server I am not able to reconfigure and runs on another machine)


I was tested this configuration on the MAC OS X machine where svn repositories 
with  conf/paswd file plain password authentication that works. It does not 
work on the slackware machine
where sasldb authentification via password database works as well.


I am not able to find out, where the problem is. 
because


A) LDAP works well on MAC and slack as well
ldapsearch -x -h ldap.stuba.sk -b "ou=People,dc=stuba, dc=sk" -W -D
"uid=fodrek,ou=People,dc=stuba,dc=sk"  uid=*fodrek*|egrep employ
Enter LDAP Password: 
employeeType: staff
employeeType: ext
employeeType: ext
employeeType: student
employeeType: staff


B) but svn does not work


 svn co svn://147.175.108.28/ldapova
Authentication realm: <svn://147.175.108.28:3690> ldap
Password for 'mini1': 
Authentication realm: <svn://147.175.108.28:3690> ldap
Username: fodrek
Password for 'fodrek': 
Authentication realm: <svn://147.175.108.28:3690> ldap
Username: fodrek
Password for 'fodrek': 
svn: Authentication error from server: SASL(-13): user not found: no secret in
database

C) svnlog on the server shows
16535 2012-04-04T15:14:46.636745Z 147.175.108.28 - - ERR
subversion/libsvn_ra_svn/streams.c 149 210002 Network connection closed
unexpectedly


D) my svnserve.conf of the ldapova repository is

anon-access = none
auth-access = write

realm = ldap
use-sasl = true

[ldap]
Server=ldap://ldap.stuba.sk/
Base=employeeType= staff,ou=People,dc=stuba,dc=sk

log_level: 7
pwcheck_method: auxprop
auxprop_plugin: ldap
mech_list: CRAM-MD5 OTP SRP PLAIN LOGIN 


E) and my /private/etc/sasluathd.conf 

ldap_servers: ldap://ldap.stuba.sk 
ldap_default_domain: stuba.sk 
ldap_search_base: OU=People,DC=stuba,DC=sk
#ldap_bind_dn: techuser@mydomain.com
#ldap_bind_pw: password
ldap_deref: never
ldap_restart: no 
#ldap_scope: sub
ldap_use_sasl: no
ldap_start_tls: no
#ldap_version: 3
ldap_auth_method: bind
ldap_filter: uid=%u
ldap_password_attr: userPassword
ldap_timeout: 10
ldap_cache_ttl: 30
ldap_cache_mem: 32768


I would like to be informed how to determine, what I was done not correct


Thank you for any help

I look forward hearing from you

Yours faithfully

Peter Fodrek


Mime
View raw message