subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Holmberg <holmb...@iar.se>
Subject Re: Strange diffs after rsync copying of working copy
Date Fri, 03 Feb 2012 17:13:22 GMT
On 02/03/2012 05:54 PM, Philip Martin wrote:
> Johan Holmberg<holmberg@iar.se>  writes:
>
>>> A similar problem here, the file in the repository should have \n line
>>> endings but the file has some \r\n line endings.  Once again committing
>>> the file should fix the problem (although mixed line endings may cause
>>> the commit to fail and require you to make them consistent before
>>> committing).
>> But here my working copy files are already UNIX text files (no \r\n
>> line endings). And Subversion refuses to commit unchanges
>> files.
> Are you trying to commit when status shows nothing (that won't work) or
> when status shows the files as modified? I'd expect the latter to work.
>

So this should work:

   $ svn co http://someserver/somedir proj
   $ touch proj/*
   $ svn ci -m"fixed line ending problems" proj

.... and it actually worked.

I think I have solved my immediate problems now.

Thanks Philip and Stefan.

/Johan Holmberg




Mime
View raw message