subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Holmberg <holmb...@iar.se>
Subject Re: Strange diffs after rsync copying of working copy
Date Fri, 03 Feb 2012 16:33:11 GMT
On 02/03/2012 04:57 PM, Philip Martin wrote:
> Johan Holmberg<holmberg@iar.se>  writes:
>
>> Yes, in one case I get a difference for the $Id$ line (from "svn diff"):
>>
>>    -$Id:$
>>    +$Id$
> OK. I think the file in the repository has '$Id:$' instead of '$Id$' for
> the keyword.  Committing the file should fix the problem.

I edited the file to actually contain $Id$ (removing the previous 
expansion present in the working copy). That seems to have solved the 
problem for that file.


>> and in the other files the "svn diff" show a difference on line
>> endings (Windows .vs. UNIX). But the files have svn:eol-style native
>> set, and appear as normal UNIX text files in the working copies.
> A similar problem here, the file in the repository should have \n line
> endings but the file has some \r\n line endings.  Once again committing
> the file should fix the problem (although mixed line endings may cause
> the commit to fail and require you to make them consistent before
> committing).

But here my working copy files are already UNIX text files (no \r\n line 
endings). And Subversion refuses to commit unchanges files. Perhaps I 
should:

- temporarily remove the "svn:eol-style native" settings + commit
- then remove any \r\n + commit
- finally add back the "svn:eol-style native" attribute

Or is there some easier way? (this three-step process seemed to work for 
the first file I tried).

/Johan Holmberg







Mime
View raw message