subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Utting <ma...@cs.waikato.ac.nz>
Subject Re: Upgrade to svn 1.7 on cygwin causes W155007 not a working copy?
Date Fri, 21 Oct 2011 00:10:53 GMT
Daniel and everyone,

On 19 October 2011 19:40, Daniel Shahaf <d.s@daniel.shahaf.name> wrote:

> Mark Utting wrote on Wed, Oct 19, 2011 at 11:40:08 +1000:
> > Summary:
> > It seems that the new top-level .svn directory spontaneously disappears
> > sometimes?
> > Which leaves me with a useless working copy...
> >
>
> Do you have some cron job or other background process that walks around and
> randomly deletes files or directories?
>

Nope.


>
> > Since svn 1.7 was incompatible with my existing working copy, I did 'svn
> > upgrade' in my top-level directory, which contains several projects from
> > different SVN repositories.  It removed all the .svn directories in most
> of
> > those subdirectories (all the ones that belonged to my main SVN
> repository),
> > but then failed to create a top-level .svn directory!
>
> Actually, it doesn't "create" a top-level .svn dir; it re-uses the .svn
> dir in the root of the 1.6 wc for itself.
>

Yes, well this is the directory that is disappearing every day or so.  It
has happened four times so far, and is a real pain, because it means that
the working copy is completely disconnected from the repository, and you
cannot use any svn commands like svn status or svn diff.  Requires lots of
manual diff commands to copy changes across to a new checkout.

I've found that if I take a backup copy of the .svn directory after each
commit, I can restore it when the .svn directory disappears, which is at
least a workaround.

The only pattern I've noticed is that the times this has happened is when
I've had Eclipse open on that working copy, and have put my laptop into
sleep/hibernate node.  After it starts up again, the .svn directory is gone
(sometimes!).


Anyway, this has been such a pain that I've given up on svn 1.7 and have
downgraded back to 1.6.17 (r1128011).

I suppose the git-svn frontend might be another option?


Thanks
Mark

Mime
View raw message