subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Sasak <andrew.sa...@gmail.com>
Subject Re: svnsync error - serialized hash missing terminator
Date Wed, 26 Oct 2011 17:30:49 GMT
I have no idea how the lockup occurred
I got no output when I ran propget
I got no output when I ran proplist
I attempted to delete the property anyway, it indicated success, but I still
get the same error.
Am I going to have to rebuild the mirror?
(Thanks for the response)

On Wed, Oct 26, 2011 at 1:22 PM, Stefan Sperling <stsp@elego.de> wrote:

> On Wed, Oct 26, 2011 at 01:13:38PM -0400, Andrew Sasak wrote:
> > I have a mirror that is synced using svnsync from the master server.
> > The master server was updated to 1.7.1 yesterday, the mirror was updated
> to
> > 1.7 last week.
> > I had a few good syncs occur yesterday after the master was updated.
> > The mirror locked up last night and was rebooted this morning.
> > Since then, I get the following error when svnsync is attempted:
> >
> > svnsync: E175002: DAV request failed; it's possible that the repository's
> > pre-revprop-change hook either failed or is non-existent
> > svnsync: E175008: At least one property change failed; repository is
> > unchanged
> > svnsync: E175002: Error setting property 'sync-lock':
> > Serialized hash missing terminator
>
> Is there an existing svn:sync-lock property on revision zero of the
> slave's repository? If so, what does it look like?
> svn propget --revprop -r0 svn:sync-lock URL_TO_REPOS
>
> It sounds asif the problem is with parsing the existing property,
> which must be done since the lock needs to be checked.
>
> How did the lock-up you mentioned happen? Is it possible that the property
> got corrupted during the lock-up? For instance, because the file
> containing the serialized lock data was not fully written to disk by
> the operating system?
>
> In any case, if the property still exists and no sync job is running
> you need to remove it because it will prevent new sync jobs.
> Any svnsync process will believe that another svnsync process is currently
> writing to the repository.
>

Mime
View raw message