subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Lock <l...@signal7.de>
Subject svn dump failure with bad revison
Date Fri, 21 Oct 2011 16:04:20 GMT
Hi,
we are using  subversion 1.6.11 (r934486) with FSFS database on  
CentOS  and i get the following error while using svnadmin dump:

* Dumped revision 8233.
svnadmin: File not found: revision 8234, path

Some times ago, we committed a file with an bad filename. I think we  
used a blank or other special characters. Afterwards we deleted this  
file so we created exactly one revision with this bad file.
Now, we are not able to dump this Repository because we get an "file  
not found!" error for that revision while dumping.

As I read in the FAQ:
http:subversion.apache.org/faq.html#removal
It´s planned to delete  revisions out of a repository but still not  
implemented and I have to pipe my dumpfile into the svndumpfilter

So I tried:
svnadmin dump REPO/ | svndumpfilter exclude revision 8234 > exclude.dump
but still get

svnadmin: File not found: revision 8234, path.....

As i´m not used to the svndumpfilter I tried different syntax (just  
8234, the path ) all with the same failure. Unfortunately the man page  
is not very helpful.

After this I tried:

svnadmin dump REPO/ 0:8233 > inkr.dump

to append the rest with a incremental dump using  >>.
But I´m wondering cause get the same failure:
....
* Dumped revision 8233.
svnadmin: File not found: revision 8234, path '/PATH'

Does anybody know how to dump a repository excluding exactly one  
revision or perhaps anybody has an other idea solving this problem.

Thanks,
Stefan

(-) Stefan Lock
(-) SIGNAL 7 Gesellschaft für Informationstechnologie mbH
(-) Pallaswiesenstraße 174 - 64293 Darmstadt,
(-) Tel: +49 (0) 6151 969 96 17, Fax: +49 (0) 6151 969 96 29
(-) mailto:lock@signal7.de, www.signal7.de
(-) Amtsgericht Darmstadt, HRB 6833
(-) Geschäftsführer: Robert Krüger, Frank Peters, Jochen Strunk


Mime
View raw message