subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Martin <philip.mar...@wandisco.com>
Subject Re: 1.7RC4 file externals produce errors on updates
Date Mon, 24 Oct 2011 21:04:25 GMT
Mothmonsterman <p.e.fletcher@gmail.com> writes:

> Should this have been resolved with Issue 4015?
>
> http://subversion.tigris.org/issues/show_bug.cgi?id=4015
>
> On Oct 17, 4:30 pm, Mothmonsterman <p.e.fletc...@gmail.com> wrote:
>> same problem here..
>>
>> On Oct 4, 1:10 pm, Rolf Campbell <rcampbell-cyg...@dragonwaveinc.com>
>> wrote:
>>
>> > When I try to update a working view that contains file-externals, I get
>> > an error because the client thinks the external is aversioneditem.
>>
>> > In an attempt to clear the problem, I deleted the file (locally), but
>> > "svn up" restores the file and then complains about itexisting.
>>
>> > Are file-externals supported in v1.7?
>>
>> > $ svn up
>> > Updating '.':
>> > Restored 'lastserial.txt'
>>
>> > Fetching externaliteminto 'lastserial.txt':
>> > svn: warning: W195017: The file external from
>> > 'https://[snip]/trunk/SerialNumbers/lastserial.txt'cannotoverwritetheexistingversionedite
mat '/c/[snip]/lastserial.txt'
>>
>> > At revision 3905.
>> > svn: E205011: Failure occurred processing one or more externals definitions

Difficult to say.  Issue 4015 is fixed in 1.7.  Are you using rc4?  Are
you using a 1.7 checkout, or a 1.6 checkout upgraded to 1.7?

-- 
Philip

Mime
View raw message