subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Podskubka <s.podsku...@hcs.at>
Subject Re: Bug report: Assertion failed during update/cleanup
Date Mon, 24 Oct 2011 14:42:53 GMT
To clarify, these were my steps:

1. upgrade a 1.6 working copy to version 1.7 using Subversion 1.7.0
2. update the working copy using Subversion 1.7.0, error occured 
(workqueue.c line 672: assertion failed (checksum != NULL) )
3. perform a cleanup on the working copy using Subversion 1.7.0, same 
error occured
4. update Subversion 1.7.0 to 1.7.1
5. try the cleanup on the working copy again using Subversion 1.7.1, 
same error occured

After that I made a fresh check-out using Subversion 1.7.1, now 
everything works fine.

I suppose the 1.6 working copy was corrupted (because of a missing 
text-base) but the working copy upgrade mechanism in Subversion 1.7.0 
did not recognize it as an error. So I ended up with a corrupt 1.7 
working copy, which led to the above mentioned error, which was not 
resolved even after updating to Subversion 1.7.1.
I suppose if I had already done the working copy upgrade with Subversion 
1.7.1 it had notified me that the 1.6 working copy was corrupt and 
wouldn't let me upgrade it to 1.7 at all, but I can't easily confirm 
that now because I don't have a backup of my old 1.6 working copy.

Best regards
Stefan


On 24.10.2011 16:20, Andreas Tscharner wrote:
> [snip]
>
>> Anyway, the same error happens with TortoiseSVN and
>> Subversion 1.7.1, so
>> is my assumption correct, that this was an error during the
>> working copy
>> upgrade process from 1.6 to 1.7 and is not fixed by updating
>> Subversion
>> but only by checking out a fresh working copy (or performing
>> the upgrade
>> from 1.6 to 1.7 with Subversion 1.7.1, which would then result in an
>> error because of a corrupt working copy)?
> Did you try from your 1.6.x working copy with version 1.7.1 or did you try on the same
working copy you've already tried v1.7.0?
>
> I am actually asking, because I am thinking about deplyoing 1.7.x in our company, but
as long as this bug is not fixed, I am hesitating...
>
> Best regards
> 	Andreas

Mime
View raw message