subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Sperling <s...@elego.de>
Subject Re: your mail
Date Wed, 26 Oct 2011 10:20:27 GMT
On Tue, Oct 25, 2011 at 05:44:50PM -0700, Gross, Joseph S wrote:
> Hi,
> 
> Encountered the following error. I had used a switch to move a large
> folder of data from a time-indexed area to an archive area.

A 'switch' is usually used to update a working copy to a different
branch. It doesn't sound like your use case applies here.
See http://svnbook.red-bean.com/nightly/en/svn.branchmerge.switchwc.html

> After the
> switch, it seemed as though the data did not move correctly, so I did
> a cleanup. In the time-indexed area I then saw some conflicted tree
> issues, and tried to look at the "edit conflict" dialogue. It gave
> options: "keep the directory from the repository" and "mark the
> conflict as resolved" since I assumed that the data was lost (I didn't
> get anything to move into the archive area) I tried keep directory
> from repository and got this error.
> 
> -Joe
> 
> [cid:image001.png@01CC933D.CBA0C160]

This is a known bug in Subversion 1.6.8 which you are running.
It has been fixed in later versions. You should upgrade to either
1.6.17 or 1.7.1.

In the future, please don't attach images, but copy/paste the error
dialog text into your email directly (press Ctrl-C in the error message
window and Ctrl-V in your email composer).

Mime
View raw message