subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Levy <andy.l...@gmail.com>
Subject Re: hook permissions, visualsvn, windows
Date Thu, 09 Jun 2011 15:46:50 GMT
On Thu, Jun 9, 2011 at 11:05, Henry Hartley <henryhartley@westat.com> wrote:
> Lorenz wrote:
>>> that doesn't look like a windows batch file to me.
>>> You sure that runs from the windows command line?
>>>
>>> Doing so on win xp gives me errors about the "REPOS=$1" and
>>> "REV=$2" lines. And the when I correct the syntax the call to svn
>>> results in svn trying to update $REPOS (literally!) and
>>> D:/Websites/wwwsite1
>>>
>>> Anyway, the syntax of the update command is:
>>>
>>>      svn up <path to working copy>
>>>
>>>no repository url/path required/allowed.
>
> I wondered about that but it worked on my old server and yes, it did run from the command
line. It complained about the lines starting with # but ignored them. Looking more closely,
it appears to have complained abou the REPOS=$1 line as well but ignored that, too. Finally,
it seems to have ignored the "$REPOS" in the update command and updated the listed working
copy.
>
> I have now shortened the file to a single line:
>
> "C:\Program Files (x86)\VisualSVN Server\bin\svn" up D:/websites/wwwsite1
>
> That runs from the command line this time without any comments or warnings. So, that's
good. It still doesn't run when I commit a change to the repository, though.
>
> I did, though, get an error in the event log this time. It seems to be complaining about
a username/password being unknown or incorrect. The user name displayed is my own. It's a
network account that happens to be an administrator on the local machine. It occurs to me,
however, that I installed VisualSVN without right-clicking and selecting "Run as Administrator."
Should I have? Would that produce the problem I'm seeing?


Does your repository require authentication for read operations (like
an update)? If so, the account that the hook script is running under
(the same one that VisualSVN Server is running under, probably Network
Service) doesn't have credentials cached, so the hook is being
prompted for credentials.

Pass  valid credentials to svn update with --username and --password
in your hook & see what happens.

Mime
View raw message