subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Levy <andy.l...@gmail.com>
Subject Re: Apache is exposing my Subversion repository internals (e.g. conf, db, hooks, etc.)
Date Fri, 24 Jun 2011 16:37:55 GMT
On Fri, Jun 24, 2011 at 12:29, Joshua Davies <joshua.davies@2xoffice.com> wrote:
> Nope, here are my modules:
> LoadModule dav_svn_module     modules/mod_dav_svn.so
> LoadModule authz_svn_module   modules/mod_authz_svn.so
> but thanks for the quick response!

Are they being loaded properly? Anything in the Apache error log?


> On Fri, Jun 24, 2011 at 11:26 AM, Stefan Sperling <stsp@elego.de> wrote:
>>
>> On Fri, Jun 24, 2011 at 11:05:32AM -0500, Joshua Davies wrote:
>> > Everything seems to be working, but when I load my repository from a web
>> > server - e.g.
>> >
>> > https://hostname/repos
>> >
>> > I see my projects listed, along with the Subversion repository
>> > internals:
>> >
>> > repos - Revision 64: /
>> >
>> >    - Project1
>> >    - README.txt <https://dev01.2xoffice.com/repos/README.txt>
>> >    - conf/ <https://dev01.2xoffice.com/repos/conf/>
>> >    - db/ <https://dev01.2xoffice.com/repos/db/>
>> >    - format <https://dev01.2xoffice.com/repos/format>
>> >    - hooks/ <https://dev01.2xoffice.com/repos/hooks/>
>> >    - P <https://dev01.2xoffice.com/repos/integration/>roject2
>> >    - locks/ <https://dev01.2xoffice.com/repos/locks/>
>> >    - Project3
>> >
>> > What have I gotten wrong here?  I'm sure there's a way to have only the
>> > projects, and not the repository internals, exposed.
>>
>> It's a wild guess, but maybe you didn't load mod_dav_svn into Apache?
>
>
>
> --
> Managing Director - Architecture
> 2Xoffice.com
> (214)636-2679
>
>

Mime
View raw message