subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sperling Stefan <s...@elego.de>
Subject Re: Compile Subversion 1.6.5 on SLES 11.1
Date Thu, 24 Feb 2011 10:45:04 GMT
On Thu, Feb 24, 2011 at 11:07:35AM +0100, Stutz Oliver wrote:
> Hi Stefan,
>  
> Thanks for your many replies.
>  
> The Reason why i want to doit like that is because SLES 11.1
> Subversion from the repository is not available. (We use a company
> internal SLES repository which is under specific company restrictions
> & security policies) but if you can confirm to me that the packages
> provided in the email will work on 11.1 without an upgrade to 11.2 or
> 11.3


There doesn't seem to be any SLES 11.2 or later release.
SLES 11.1 is the latest (it's labelled as "SLES 11 service pack 1"
on the novell website).

There aren't any separate Subversion package repositories for point
releases of any SLES version on the build service.
I suppose that's because all the point releases seem to contain is
security and bug fixes. Browsing the release notes for 11.1 at
http://www.novell.com/linux/releasenotes/x86_64/SUSE-SLES/11-SP1/
there don't seem to be any changes that would prevent subversion
packages compiled for SLES 11 to stop working on SLES 11.1.
The list at http://en.opensuse.org/openSUSE:Build_Service_supported_build_targets
doesn't list SLES 11.1 separately either.

> I would be very happy (it would be awesome and safe worktime).

Not only does it save time, it also makes it easier to get important
bugfixes quickly. The packages on the build service are kept up-to-date.
Whenever a new Subversion release is made, there will be a corresponding
update on the buildservice a few days later (and especially fast if the
new Subversion release fixes security issues). You can receive this update
via yast just like any other update.

Mime
View raw message