subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Sperling <s...@elego.de>
Subject Re: missing carriage returns from output of "svn diff" in Windows
Date Tue, 01 Feb 2011 23:35:02 GMT
On Tue, Feb 01, 2011 at 12:39:29PM -0800, David Chapman wrote:
> 0000000   I   n   d   e   x   :       s   v   n   _   u   s   a   g   e
> 0000020   _   n   o   t   e   s   .   t   x   t  \r  \n   =   =   =   =
> 0000040   =   =   =   =   =   =   =   =   =   =   =   =   =   =   =   =
> *
> 0000120   =   =   =   =   =   =   =   =   =   =   =   =   =   =   =  \r
> 0000140  \n   -   -   -       s   v   n   _   u   s   a   g   e   _   n
> 0000160   o   t   e   s   .   t   x   t  \t   (   r   e   v   i   s   i
> 0000200   o   n       1   1   1   6   )  \r  \n   +   +   +       s   v
> 0000220   n   _   u   s   a   g   e   _   n   o   t   e   s   .   t   x
> 0000240   t  \t   (   w   o   r   k   i   n   g       c   o   p   y   )
> 0000260  \r  \n   @   @       -   6   1   2   2   ,   3       +   6   1
> 0000300   2   2   ,   6       @   @  \r  \n      \n       M   a   r   k
> 0000320       P   h   i   p   p   a   r   d  \n       h   t   t   p   :
> 0000340   /   /   m   a   r   k   p   h   i   p   .   b   l   o   g   s
> 0000360   p   o   t   .   c   o   m   /  \n   +   f   o   o      \n   +
> 0000400   b   a   r      \n   +   z   o   t      \n
> 0000413
> 
> Note how the first part of the file has "\r\n" while the last part
> (showing the extra lines) has only '\n'.  The file itself has "\r\n"
> for every line, and I have the following line in
> C:\Users\David\AppData\Roaming\Subversion\config:
> 
> *.txt = svn:eol-style=native

This is a known issue:
http://subversion.tigris.org/issues/show_bug.cgi?id=3338

Stefan

Mime
View raw message