subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giulio Troccoli <Giulio.Trocc...@uk.linedata.com>
Subject RE: Subversion on AIX
Date Wed, 13 Oct 2010 15:09:03 GMT
>


Linedata Limited
Registered Office: 85 Gracechurch St., London, EC3V 0AA
Registered in England and Wales No 3475006 VAT Reg No 710 3140 03

-----Original Message-----


> From: David Weintraub [mailto:qazwart@gmail.com]
> Sent: 13 October 2010 16:01
> To: Giulio Troccoli
> Cc: Subversion
> Subject: Re: Subversion on AIX
>
> I just tried building APR with your proceedure and socktest
> still fails. Did you run the tests? I suspect that this
> particular test might not be that important.

I think I did, sorry I don't remember. If I did, it either passed or it was skipped. I'll
try and run them again and let you know

> On Wed, Oct 13, 2010 at 3:49 AM, Giulio Troccoli
> <Giulio.Troccoli@uk.linedata.com> wrote:
> >>
> >
> >
> > Linedata Limited
> > Registered Office: 85 Gracechurch St., London, EC3V 0AA
> Registered in
> > England and Wales No 3475006 VAT Reg No 710 3140 03
> >
> > -----Original Message-----
> >
> >
> >> From: David Weintraub [mailto:qazwart@gmail.com]
> >> Sent: 12 October 2010 18:41
> >> To: Subversion
> >> Subject: Subversion on AIX
> >>
> >> We are trying to get a Subversion install on an IBM AIX
> box we have
> >> here. Unfortunately, I really don't have root access to
> the box, and
> >> I know that our admins will probably not be very helpful in this
> >> endeavor.
> >>
> >> I do have gcc version 4.0.0, but I don't have the APR library. We
> >> don't plan to use Apache httpd, but just svnserve instead.
> >>
> >> I downloaded the Universal AIX tarball (only 1.4, but I'd be happy
> >> with anything now), and had problems since it was tarred up at the
> >> root of the directory. I used pax to untar the file, so I
> could put
> >> it under something besides /opts.
> >> The files are placed under /home/david.
> >>
> >> $ LIBPATH=/home/david/subversion/opt/subversion/lib:$LIBPATH
> >> $ ./svn
> >> exec(): 0509-036 Cannot load program ./svn because of the
> following
> >> errors:
> >>         0509-022 Cannot load module
> >> /home/david/subversion/opt/subversion/lib/libsvn_client-1.so.
> >>         0509-150   Dependent module
> >> /opt/subversion/lib/libsvn_wc-1.so
> >> could not be loaded.
> >>         0509-022 Cannot load module
> >> /opt/subversion/lib/libsvn_wc-1.so.
> >>         0509-026 System error: A file or directory in the
> path name
> >> does not exist.
> >>         0509-022 Cannot load module svn.
> >>         0509-150   Dependent module
> >> /home/david/subversion/opt/subversion/lib/libsvn_client-1.so
> >> could not be loaded.
> >>         0509-022 Cannot load module .
> >>
> >> Any ideas at this point?
> >>
> >
> > I have successfully compiled Subversion 1.6.9 on both AIX
> 4.3 and 5.3. The following is for AIX 5.3 and with user dev.
> You will need to change all the reference to ~dev to the
> correct user (or different path altogether). Also, these
> instruction do not specify any --prefix, because I wanted to
> install SVN in the standard directory. However, I have used
> the exact same instruction for testing 1.6.9 prior to
> installation and it that case I used the --prefix. As long as
> you specify the same location for --prefix everything should work.
> >
> > cd ~dev
> > gunzip -c subversion-deps-1.6.9.tar.gz | tar xvf - gunzip -c
> > subversion-1.6.9.tar.gz | tar xvf - cd ~dev/subversion-1.6.9/apr
> > CC="/usr/vac/bin/cc" \
> > CFLAGS="-qmaxmem=-1 -O2 -qlanglvl=extended" \ ./configure \
> > --enable-shared \ --enable-static make make install cd
> > ~dev/subversion-1.6.9/apr-util/xml/expat
> > CC="/usr/vac/bin/cc" \
> > CFLAGS="-qmaxmem=-1 -O2 -qlanglvl=extended" \ ./configure \
> > --enable-shared=yes make make install cd
> > ~dev/subversion-1.6.9/apr-util CC="/usr/vac/bin/cc" \
> > CFLAGS="-qmaxmem=-1 -O2 -qlanglvl=extended" \ ./configure \
> > --with-apr=/usr/local/apr \ --with-expat=builtin make make
> install cd
> > ~dev/subversion-1.6.9/neon CC="/usr/vac/bin/cc" \
> > CFLAGS="-qmaxmem=-1 -O2 -qlanglvl=extended" \
> > CPPFLAGS="-I/usr/local/include" \ LDFLAGS="-brtl" \ ./configure \
> > --with-expat=/usr/local/lib/libexpat.la \ --enable-shared=yes make
> > make install cd ~dev/subversion-1.6.9 CC="/usr/vac/bin/cc" \
> > CFLAGS="-qmaxmem=-1 -O2 -qlanglvl=extended" \
> > CPPFLAGS="-I/usr/local/include" \ LDFLAGS="-L/usr/local/lib" \
> > ./configure \ --disable-shared \ --without-ssl \
> --without-berkeley-db
> > \ --with-apr=/usr/local/apr \ --with-apr-util=/usr/local/apr \
> > --without-apxs \ --with-neon=/usr/local \ --without-serf make make
> > install
> >
> > I found that the order of the installation was important,
> e.g expat before apr-util. Also, you may need to use the
> --with-sqlite option when configuring Subversion to point to
> sqlite3.c in the Subversion dependency tree (I had SQLite
> installed). And obviously you can change other option to
> consifure Subversion for your needs.
> >
> > Giulio
> >
>
>
>
> --
> David Weintraub
> qazwart@gmail.com

Mime
View raw message