subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Westerman <dlwes...@us.ibm.com>
Subject SVN Phantom Directory Problems
Date Thu, 17 Dec 2009 18:55:58 GMT
I'm having problems with a directory that has been deleted, but is 
preventing me from being able to commit changes to SVN.

I created a branch, and am now done with it. I've tried to merge it back 
into the trunk, for which I have a brand new checked-out working copy. The 
way SVN is set up here, I can't do a 'merge --reintegrate' (although I 
don't know that this has anything to do with my issue).

I did the merge, and dealt with the conflicts, except for this one 
conflict with a directory that used to exist ('xml-ND'). I deleted the 
directory after I created the branch - from both the trunk and the branch. 
But the merge flagged it as a conflict, even though it doesn't exist in 
the trunk or the branch or my working copy.

I tried to do a commit, and got the following error message:
svn: Commit failed (details follow):
svn: Aborting commit: 
'/home/dlwester/SVN/MiddlewareMigrationScripts/WasUcmPlugin/xml-ND' 
remains in conflict

I tried to delete this subdirectory, with 'svn delete', in the trunk and 
the branch and the working copy, but it tells me it doesn't exist. I even 
used the '--force' option, which had no effect.

I looked in the .svn/entries file, and see this entry for the 
subdirectory:
((conflict xml-ND dir merge deleted deleted (version 
https://svn.cs.opensource.ibm.com/svn/zgears 4 3610 
MiddlewareMigrationScripts/WasUcmPlugin/xml-ND dir) (version 
https://svn.cs.opensource.ibm.com/svn/zgears 4 4273 
MiddlewareMigrationScripts/WasUcmPlugin.branch.ND/xml-ND dir)))

I don't know what to do at this point. How can I get rid of this "phantom" 
entry for this subdirectory, so that SVN will allow me to do the commit?
Mime
View raw message