subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko Čibej <br...@wandisco.com>
Subject Re: 1.7.19 and 1.8.11 [was: svn commit: r1645547 - in /subversion/branches: 1.7.x/STATUS 1.8.x/STATUS]
Date Mon, 15 Dec 2014 12:33:01 GMT
On 15.12.2014 13:23, Julian Foad wrote:
> Branko Čibej wrote:
>
>> On 15.12.2014 04:30, Ben Reser wrote:
>>>  On 12/14/14 6:11 PM, Branko Čibej wrote:
>>>>  As you've all seen, I voted against releasing 1.7.19 and 1.8.11, because
>>>>  the DAV tests don't work with HTTPd 2.4+, which is the system default on
>>>>  the latest version of OSX. I'd be surprised if OSX is the exception; it
>>>>  seems to depend not just on the HTTPd version but also on the configured
>>>>  MPM.
>>>>
>>>>  I found that we've had the fix on trunk in davautocheck.sh for over a
>>>>  year, and have proposed to backport it to 1.7.x and 1.8.x; it's a clean
>>>>  merge.
>>>>
>>>>  I therefore propose that we scratch the 1.7.19 and 1.8.11 releases,
>>>>  approve the backport and roll 1.7.20 and 1.8.12 with the fix included.
>>>  I don't disagree we should fix this.  But it's not a regression.
>> No, it isn't, which is why I wrote "vote against", not "veto". But it's
>> an easily-fixed nuisance. ISTR Julian mentioned he had similar
>> intermittent problems on Linux ... which might nor might not have the
>> same cause.
> Since upgrading to Ubuntu 14.04 which has httpd 2.4, I found 'davautocheck' fails at
the configuration checking stage:
>
>   AH00534: apache2: Configuration error: No MPM loaded.
>   davautocheck.sh: Configuration file didn't pass the check, most likely
>   modules couldn't be loaded

That's a different issue, i.e., there's no default MPM compiled into HTTPd.

> On
>  bypassing the checks in davautocheck.sh, httpd failed to start. At one point while experimenting
with these things, the OS crash reporter reported that httpd had crashed, but I don't know
which attempt that was.
>
> I tried going back to Subversion 1.8.8 and 1.8.0 they fail in the same way.
>
> Setting
>  'APACHE_MPM=worker' made the test suite work and pass all tests. Although it's nice
if everything works automatically, this is good 
> enough for me.
>
> Later I tried with 'prefork', and that works too, and all tests pass. But with 'APACHE_MPM=event',
usually (but not always) some tests fail (for example, one or more of: externals_tests.py
2 5 7 12 15; merge_automatic_tests.py 13).
>
> Does that appear to be the same issue you found? 

No; I suggest trying with APACHE_MPM=prefork with the current state of
the 1.8.x branch, that's a more likely trigger. Unless 2.4 behaves
differently on Linux and doesn't require a lock file for prefork.

-- Brane


>
> You also reported:
>>   - Two swig-rb tests fail:
>>
>>     -- SvnClientTest#test_diff
>>     -- SvnClientTest#test_diff_peg
>>
>>     It looks like these tests should use the --internal-diff flag,
>>     or create their own config directory; i.e., this is a bug in
>>     the tests rather than in the bindings.
>>
>>     (My default svn config sets diff-cmd to colorize the diff output,
>>      which causes the regular expressions in the test to not match.)
> The
>  swig-rb tests use the Subversion configuration in the user's home 
> directory and fail or behave differently if you have certain settings 
> there. (In my case, Subversion 'diff' pops up a GUI.) They should 
> instead use their own config dir.
>
> I tried with various 1.8.x tags and found this problem was introduced in 1.8.9.
>
> I worked around that problem by setting environment variable 'HOME' to a temporary directory.

Yup, this is really a minor bug in the test suite.

-- Brane


Mime
View raw message