subversion-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johan Corveleyn <>
Subject error testing pcre
Date Sun, 02 Jun 2013 08:25:08 GMT
I decided to give my dev environment a spring cleaning, and tried to build the dependencies (great work BTW,
looking forward to having less dependency-building-worries -- thanks).
However, I ran into a problem when the testsuite of pcre was run:

(complete output in attachment)

Running tests...
When testing is complete, review test output in the

Test project C:/research/svn/client_build/deps/build/httpd/srclib/pcre
    Start 1: pcre_test_bat
1/4 Test #1: pcre_test_bat ....................***Failed  Required
regular expression not found.Regex=[RunTest\.bat tests successfully
]  2.89 sec
    Start 2: pcrecpp_test
2/4 Test #2: pcrecpp_test .....................   Passed    0.03 sec
    Start 3: pcre_scanner_test
3/4 Test #3: pcre_scanner_test ................   Passed    0.03 sec
    Start 4: pcre_stringpiece_test
4/4 Test #4: pcre_stringpiece_test ............   Passed    0.03 sec

75% tests passed, 1 tests failed out of 4

Total Test time (real) =   3.08 sec

The following tests FAILED:
          1 - pcre_test_bat (Failed)
Errors while running CTest
NMAKE : fatal error U1077: 'echo' : return code '0x8'
Failure testing pcre (exit code: 512) at
C:\research\svn\client_build\deps\ line 245.

When I look at the test output in .../Testing/Temporary, the
LastTest.log contains the following:

---- Testing 8-bit library ----

Test 1: "Main functionality (Compatible with Perl >= 5.10)"
Test 1: "Test with Study Override"
Test 2: "API, errors, internals, and non-Perl stuff"
          failed comparison: fc /n

** Test 2 requires a lot of stack. PCRE can be configured to
** use heap for recursion. Otherwise, to pass Test 2
** you generally need to allocate 8 mb stack to PCRE.
** See the 'pcrestack' page for a discussion of PCRE's
** stack usage.

So perhaps this test won't run on my ancient Windows XP (no idea why
others wouldn't get this error, and I would).

Googling a bit, I found that "stack recursion" can be disabled in
pcre, to avoid this problem, so perhaps the solution is to disable
stack recursion when configuring pcre? The PCRE configuration summary
in the build output currently says:

    --   No stack recursion .............. : OFF

Or perhaps another solution is better? I don't know much about
(building) pcre ...

Another approach might be that I not run the testsuite of pcre, but
I'm not sure what I would miss then.

Anyone any suggestions?

BTW: currently it's hard to redirect the output of to a file. I scraped the output of my console
window, because redirecting it with "> buildout.log" would only
capture part of the output (perhaps not everything is written to
stdout). Automatically tee-ing the output to a file would be a nice
improvement to the script :-). Just a thought ...


View raw message