struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christoph Nenning <Christoph.Nenn...@lex-com.net>
Subject Antwort: RE: Running Struts 2 Project in WebSphere Application Serve 7.0.0.19
Date Mon, 24 Mar 2014 08:18:04 GMT
> I think you should change the the class loader priority in your 
websphere.
> * Click on WebSphere enterprise applications.
> * Choose your enterprise application
> * Click on Manage Modules.
> * Click on your module.
> * "Select Classes loaded with local class loader first (parent 
> last)" from the Class loader order drop
> down list.
> * Click on OK.
> * Click on Save.
> * restart the websphere
> 


you can automate this by adding a file to your EAR project:

/META-INF/ibmconfig/cells/defaultCell/applications/defaultApp/deployments/defaultApp/
deployment.xml


content:



<?xml version="1.0" encoding="UTF-8"?>
<appdeployment:Deployment
        xmi:version="2.0"
        xmlns:xmi="http://www.omg.org/XMI"
        xmlns:appdeployment="
http://www.ibm.com/websphere/appserver/schemas/5.0/appdeployment.xmi">

        <deployedObject xmi:type="appdeployment:ApplicationDeployment" 
startingWeight="10">

                <modules 
                        xmi:type="appdeployment:WebModuleDeployment"
                        startingWeight="10000" 
                        uri="<your war name>" 
                        classloaderMode="PARENT_LAST" />
                <classloader mode="PARENT_LAST" />
        </deployedObject>
</appdeployment:Deployment>



regards,
Christoph

This Email was scanned by Sophos Anti Virus

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message