struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "andy wix" <>
Subject OT: Runtime exec (again)
Date Thu, 02 Dec 2004 09:10:45 GMT

Still can't get this to work.

There must be some reason why this won't run under Tomcat but does work 
stand-alone. I have also tried the Tomcat list to no avail.

To recap, I am trying to execute the following code on an Xp box with Tomcat 

Process proc = runtime.exec("cmd.exe /C shutdown -r -f -m \\myPC -t 50");
int exitVal = proc.waitFor();

When this runs the proc exits with a value of 0 but nothing happens (no 
re-boot) and no exceptions are thrown.

I have tried running the code from a batch file and without the cmd.exe /C 

I have tried running Tomcat from the command line (not as service).

I have tried allowing all permissions in the catalina.policy file:
grant codeBase "file:${catalina.home}/webapps/ROOT/WEB-INF/classes/-" {
   permission "*";

I CAN successfully set the the system time and date using the same approach

I have absolutely no idea on this now.


It's fast, it's easy and it's free. Get MSN Messenger today!

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message