storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonas Krauss <jkraus...@gmail.com>
Subject Storm UI Assigned Mem
Date Wed, 12 Dec 2018 13:16:43 GMT
Hi all,

we are currently using storm 1.2.2 together with zookeeper 3.4.11. The
value for assigned mem per topology in the storm ui under topology summary
always displays 65, even though we assign xmx4096m by default through the
storm.yaml.

The workers are correctly started with -xmx4096m though. However, when
overriding the worker.childopts parameter in an individual topology the
workers are not using the new value but stick with the default. We try
overriding e.g. by doing

conf.setTopologyWorkerMaxHeapSize(7168);
conf.put("worker.childopts", "-Xms128m -Xmx8192m");
conf.put("worker.heap.memory.mb", 8192);

The values are correctly displayed in the individual topology ui screen
config section but not used for starting up the jvm workers.

Are both problems related? How can we have the storm ui displayed the
correct values and how can we override the default value so storm actually
uses the new provided one?

Any help is greatly appreciated.

Regards

Jonas

PS.
This is our storm.yaml:

nimbus.childopts: "-Xms128m -Xmx2048m"
ui.childopts: "-Xms128m -Xmx1024m"
supervisor.childopts: "-Xms128m -Xmx2048m"
worker.childopts: "-Xms128m -Xmx4096m"

supervisor.slots.ports:
    - ...

supervisor.worker.timeout.secs: 120

worker.heartbeat.frequency.secs: 5

Mime
View raw message