The issue was is that I used the same zookeeper that was used with storm 0.10.0.  I was getting bizarre errors.  So I stopped zookeeper, manually destroyed purged the data, then started it back up.  Afterwards, everything worked well (sell almost, a supervisor had bad data in appdir, once cleared out, worked).

On Fri, Sep 9, 2016 at 4:30 AM, Alberto São Marcos <alberto.csm@gmail.com> wrote:
Can you run a cluster with one nimbus? Yes you can.
Check your network.

On Thu, Sep 8, 2016 at 8:29 PM, Joaquin Menchaca <jmenchaca@gobalto.com> wrote:
Can you run a cluster with one nimbus?  I am stuck at the moment, maybe doing something dumb.

I am getting:

org.apache.storm.utils.NimbusLeaderNotFoundException: Could not find leader nimbus from seed hosts ["nimbus-stormcluster.gobalto.com"]. Did you specify a valid list of nimbus hosts for config nimbus.seeds?

I only have one nimbus in my cluster:

storm.zookeeper.servers:
- "zookeeper-stormcluster.gobalto.com"

nimbus.seeds
: ["nimbus-stormcluster.gobalto.com"]
nimbus.childopts
: "-Xmx1024m -Djava.net.preferIPv4Stack=true"
ui.childopts: "-Xmx768m -Djava.net.preferIPv4Stack=true"

supervisor.childopts
: "-Djava.net.preferIPv4Stack=true"
worker.childopts: "-Xmx768m -Djava.net.preferIPv4Stack=true"
supervisor.slots.ports:
- 6700
- 6701
- 6702
- 6703

storm.local.dir: "/app/storm"

I also have a hosts file, like this:

127.0.0.1 localhost nimbus-stormcluster.gobalto.com
10.110.20.8 zookeeper-stormcluster.gobalto.com
10.110.20.10 supervisor1-stormcluster.gobalto.com
10.110.20.11 supervisor2-stormcluster.gobalto.com
10.110.20.9 supervisor3-stormcluster.gobalto.com





--

是故勝兵先勝而後求戰,敗兵先戰而後求勝。





--

是故勝兵先勝而後求戰,敗兵先戰而後求勝。