storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Xor <andreas.gramme...@gmail.com>
Subject Re: Error in storm-starter: Could not find artifact 0.10.0-SNAPSHOT in clojars
Date Tue, 10 Feb 2015 00:30:32 GMT
No, this is actually one of the most common pitfalls (and subsequently
question) that we see here; you have to actually go to the pom.xml that is
located in storm-starter folder and change the dependency scope of
storm-core (which is the <scope> </scope> tag) from whatever it is to
"compile" (without the ""). This should (hopefully) solve your problem...

Regards,

A.

On Tue, Feb 10, 2015 at 2:02 AM, Mike Clarke <mike.k.clarke@gmail.com>
wrote:

> It's likely you didn't run the mvn command from the top level "storm"
> directory, as it notes in the readme:
>
> ```
> # Must be run from the top-level directory of the Storm code repository
> $ mvn clean install -DskipTests=true
> ```
>
> Try re-running the `mvn clean install` command from the top-level of your
> checkout. Then, future `mvn` commands should be run from the
> examples/storm-starter directory if you're looking to try the example word
> count topologies.
>
> On Mon, Feb 9, 2015 at 3:52 PM, Jon Gregg <jonrgregg@gmail.com> wrote:
>
>> I cloned storm-starter from
>> https://github.com/apache/storm/tree/master/examples/storm-starter, then
>> went to build my jar locally using "mvn clean install -DskipTests=true"
>>
>>  Here's the error I got:
>>
>> [ERROR] Failed to execute goal on project storm-starter: Could not
>> resolve depen
>> dencies for project org.apache.storm:storm-starter:jar:0.10.0-SNAPSHOT:
>> Could no
>> t find artifact org.apache.storm:storm-core:jar:0.10.0-SNAPSHOT in
>> clojars (http
>> s://clojars.org/repo/) -> [Help 1]
>>
>> Maybe I'm looking at the wrong location, but I don't see "storm" listed
>> at https://clojars.org/repo/org/apache/
>>
>> How can I make this work?
>>
>> Jon
>>
>>
>

Mime
View raw message