storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinay Pothnis <vinay.poth...@gmail.com>
Subject Re: http-client version conflict
Date Wed, 05 Feb 2014 16:55:58 GMT
Thank you! Will take a look at this.

-Vinay


On Wed, Feb 5, 2014 at 7:31 AM, P. Taylor Goetz <ptgoetz@gmail.com> wrote:

> Your best bet is probably  to use the shade plugin to relocate the
> http-client package so it doesn't conflict with the version storm uses.
>
> Storm does this with the libtrhift dependency in storm-core:
>
>
> https://github.com/apache/incubator-storm/blob/master/storm-core/pom.xml#L220
>
> (You can ignore the clojure transformer in that config, unless you have
> non-AOT clojure code that uses the http-client library).
>
> More information on using the shade plugin to do package relocations can
> be found here:
>
>
> http://maven.apache.org/plugins/maven-shade-plugin/examples/class-relocation.html
>
> - Taylor
>
> On Feb 4, 2014, at 4:27 PM, Vinay Pothnis <vinay.pothnis@gmail.com> wrote:
>
> > Hello,
> >
> > I am using storm version 0.9.0.1.
> > My application depends on apache http-client version 4.3.2 - but storm
> depends on http-client version 4.1.1.
> >
> > What is the best way to override this dependency?
> >
> > Thanks
> > Vinay
>
>

Mime
View raw message