storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Rose <mich...@fullcontact.com>
Subject Re: http-client version conflict
Date Thu, 06 Feb 2014 22:38:38 GMT
We've done this with SLF4j and Guava as well without issues.

Michael Rose (@Xorlev <https://twitter.com/xorlev>)
Senior Platform Engineer, FullContact <http://www.fullcontact.com/>
michael@fullcontact.com


On Thu, Feb 6, 2014 at 3:03 PM, Mark Greene <mark@evertrue.com> wrote:

> We had this problem as well. We modified our chef cookbook to just replace
> the older version with the newer one and storm didn't complain or have any
> other issues as a result.
>
>
> On Wed, Feb 5, 2014 at 10:31 AM, P. Taylor Goetz <ptgoetz@gmail.com>wrote:
>
>> Your best bet is probably  to use the shade plugin to relocate the
>> http-client package so it doesn't conflict with the version storm uses.
>>
>> Storm does this with the libtrhift dependency in storm-core:
>>
>>
>> https://github.com/apache/incubator-storm/blob/master/storm-core/pom.xml#L220
>>
>> (You can ignore the clojure transformer in that config, unless you have
>> non-AOT clojure code that uses the http-client library).
>>
>> More information on using the shade plugin to do package relocations can
>> be found here:
>>
>>
>> http://maven.apache.org/plugins/maven-shade-plugin/examples/class-relocation.html
>>
>> - Taylor
>>
>> On Feb 4, 2014, at 4:27 PM, Vinay Pothnis <vinay.pothnis@gmail.com>
>> wrote:
>>
>> > Hello,
>> >
>> > I am using storm version 0.9.0.1.
>> > My application depends on apache http-client version 4.3.2 - but storm
>> depends on http-client version 4.1.1.
>> >
>> > What is the best way to override this dependency?
>> >
>> > Thanks
>> > Vinay
>>
>>
>

Mime
View raw message