i really wonder why storm jar can't find or loadmain class of wordcounttopology ..?


On Thu, Jan 2, 2014 at 12:38 AM, researcher cs <prog.researcher@gmail.com> wrote:
Nathan , i tried searching WordCountTopology in storm-starter
wrote this command
user@ubuntu:~/Storm/storm-0.8.2$ jar -tf storm-starter.jar
and got
storm-starter/src/jvm/storm/starter/WordCountTopology.java


On Tue, Dec 31, 2013 at 10:59 PM, Nathan Leung <ncleung@gmail.com> wrote:

Yes

On Dec 31, 2013 2:58 PM, "researcher cs" <prog.researcher@gmail.com> wrote:
Nathan , Do you mean by jar -tf for searching WordCountTopology in storm-starter.jar or what ... ?


On Tue, Dec 31, 2013 at 9:24 PM, Nathan Leung <ncleung@gmail.com> wrote:

If the jar file is in fact in the location you expect it you can also jar -tf on the file and search for the WordCountTopology.

On Dec 31, 2013 1:37 PM, "researcher cs" <prog.researcher@gmail.com> wrote:
Yes,Nathan I've storm-starter.jar and installed maven and run topology successfully


On Tue, Dec 31, 2013 at 3:06 PM, Nathan Leung <ncleung@gmail.com> wrote:

Do you have a file storm-starter.jar? This doesn't match the snapshot naming that maven created for the "with dependencies" jar file. Also did you do mvn install?

-Nathan

On Dec 31, 2013 12:55 AM, "researcher cs" <prog.researcher@gmail.com> wrote:
Thanks Abhishek for replying
Steps
1- After installed storm .. i downloaded storm-starter to run it on storm
2- running WordCountTopology using maven "build successfully"
3- trying to submit a topology on storm ui . using storm jar
4- i used storm jar SNAPSHOT with dependencies and worked well ..
5- trying to use storm jar  user@ubuntu:~/Storm/storm$ bin/storm jar storm-starter.jar storm.starter.WordCountTopology wordcount but it didn't work got this error "cannot find or load main class of WordCountTopology"

but i want to tell you something i guessed that it's the reason
when i imported package of storm starter in Eclipse to run code of it .. i found error it's backtype package not defined !!


On Tue, Dec 31, 2013 at 6:44 AM, Abhishek Bhattacharjee <abhishek.bhattacharjee11@gmail.com> wrote:
What are you doing exactly could you send the steps you are following ? If you are having problems with mvn use lein.
Send the logs of what you are doing that will help us understand why exactly you are getting the error.


On Tue, Dec 31, 2013 at 4:15 AM, researcher cs <prog.researcher@gmail.com> wrote:
Thanks Aniket

problem still persist after mvn clean install

for your question do you mean that
/home/usr/Storm/storm/storm-starter/src/jvm/storm/starter/
WordCountTopology.java



On Mon, Dec 30, 2013 at 10:25 AM, Aniket Alhat <aniket.alhat@gmail.com> wrote:
Don't forget to rename file m2-pom.xml to pom.xml and also post your directory "tree" structure. I want to check whether your source WordCountTopology.java exists or not.


On Mon, Dec 30, 2013 at 10:52 AM, Aniket Alhat <aniket.alhat@gmail.com> wrote:

cd Storm
cd storm
mvn clean install
bin/storm jar /home/user/storm/storm-starter.jar "storm.starter.WordCountTopology"

On Dec 30, 2013 4:41 AM, "researcher cs" <prog.researcher@gmail.com> wrote:
Thanks Abhishek but i'm still until now have problem to find or load main class when i wrote this command
user@ubuntu:~/Storm/storm$ bin/storm jar /home/user/storm/storm-starter.jar storm.starter.WordCountTopology wordcount !!



On Sun, Dec 29, 2013 at 10:17 AM, Abhishek Bhattacharjee <abhishek.bhattacharjee11@gmail.com> wrote:
It seems at the first try the .jar file was not created and that is why the class file could not be found. And while submitting the topology you should submit the whole path(i.e the absolute path of the jar file).
The command  mvn -f m2-pom.xml compile exec:java -Dstorm.topology=storm.starter.WordCountTopology
is used to run the topology. If you just want to build the jar file use mvn package or lein uberjar.

The second question about the jar with dependecies , a standalone jar is a smaller jar and it doesn't have all the class files that are necessary to run a Topology whereas a jar with dependencies is a much bigger jar with all the dependencies. But I think from storm perspective you should use the standalone jar not the jar with dependencies.
I hope this helps. If you find something wrong please revert back. 

Cheers,
Abhishek Bhattacharjee
Pune Institute of Computer Technology




--




--
Abhishek Bhattacharjee
Pune Institute of Computer Technology