storm-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (STORM-186) Milliseconds level tick tuple is broken
Date Wed, 19 Feb 2014 16:24:21 GMT

    [ https://issues.apache.org/jira/browse/STORM-186?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13905636#comment-13905636
] 

ASF GitHub Bot commented on STORM-186:
--------------------------------------

Github user xiaokang commented on the pull request:

    https://github.com/apache/incubator-storm/pull/37#issuecomment-35516672
  
    hi @nathan,  the root cause is that the original code "(* 1000 (long delay-secs))" will
lost decimal part of delay-secs if it is a float or double value instead of an integer. For
example if delay-secs is 1.5 we expect the result is 1500 ms but the result will be 1000 *
1 = 1000.


> Milliseconds level tick tuple is broken
> ---------------------------------------
>
>                 Key: STORM-186
>                 URL: https://issues.apache.org/jira/browse/STORM-186
>             Project: Apache Storm (Incubating)
>          Issue Type: Bug
>            Reporter: James Xu
>
> dicussed here:http://mail-archives.apache.org/mod_mbox/incubator-storm-user/201312.mbox/%3CCAO%2Bnwyu4pcwarsY-GE%3DKz4GfjoRJCDC5fM6eOyYEkwj9WiJvJA%40mail.gmail.com%3E



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message