storm-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Joseph Evans (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (STORM-70) use zookeeper-3.4.5
Date Fri, 28 Feb 2014 17:06:23 GMT

    [ https://issues.apache.org/jira/browse/STORM-70?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13916014#comment-13916014
] 

Robert Joseph Evans commented on STORM-70:
------------------------------------------

Wow Derek that is it!!!!

I added the following to me test, and it solved the issue.
System.setProperty("java.net.preferIPv4Stack" , "true");

I'll update my patch, to include the prefer IPV4 for the maven tests by default but with an
option that it can be turned off.

> use zookeeper-3.4.5
> -------------------
>
>                 Key: STORM-70
>                 URL: https://issues.apache.org/jira/browse/STORM-70
>             Project: Apache Storm (Incubating)
>          Issue Type: Improvement
>            Reporter: James Xu
>            Priority: Minor
>         Attachments: STORM-70-1.patch
>
>
> zookeeper 3.4.5 is commonly used in production.
> And a number of critical bugs exit in 3.3.3.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message