storm-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Solbak <s...@solbak.ca>
Subject storm-deploy on storm >= 0.9.0
Date Sun, 09 Feb 2014 17:47:08 GMT
I spent about the entire day yesterday trying to do the basic storm deploy
commands.  I've tried on ubuntu, mac and a aws box.  The deploy works for
storm 0.8.2 but our topoligies are written with storm 0.9.0.1.

The error I'm getting is (I think its the first one)

bash: bin/build_release.sh: No such file or directory


The commands Im using are (Ive tried numerous branches)

lein deploy-storm --start --name test
lein deploy-storm --start --name test --branch 0.9.0.1
lein deploy-storm --start --name test --branch 0.9.0

My config is as follows.  I was testing with t1.micros but now on m1.smalls.

*clusters.yaml*
nimbus.image: "us-west-2/ami-84d7b7b4"
nimbus.hardware: "m1.small"

supervisor.count: 2
supervisor.image: "us-west-2/ami-84d7b7b4"
supervisor.hardware: "m1.small"
#supervisor.spot.price: 1.60

zookeeper.count: 1
zookeeper.image: "us-west-2/ami-84d7b7b4"
zookeeper.hardware: "m1.small"

*config.clj*
(defpallet
  :services
  {
   :default {
             :blobstore-provider "aws-s3"
             :provider "aws-ec2"
             :environment {:user {:username "storm"
                                  :private-key-path "/path/to/key.pem"
                                  :public-key-path "/path/to/key.pub"}
                           :aws-user-id "1325-1156-9347"}
             :identity "xxxxxxx"
             :credential "xxxxxxx"
             :jclouds.regions "us-west-2"
             }
    })

Is there something obvious Im missing?

-- 
Thanks,
Sean

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message