qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Authentication newbie help sought - I'm afraid I'm failing at the first hurdle :-(
Date Thu, 06 Oct 2011 14:54:30 GMT
On 10/05/2011 07:37 PM, fadams wrote:
> There is now a --sasl-config option to qpidd; does that solve the issue
> adequately?
> Sam Hendley added a comment - 21/Jul/11 19:00
> I just tried this on ubunutu and it doesn't seem to have any affect. I see
> the log message in the qpidd logs:
> info SASL: config path set to /etc/sasl2/qpidd.conf
> But when I try connecting it is still looking at /etc/sasldb2. I verified
> this by adding different users to /etc/sasldb2 and
> /var/lib/qpidd/qpidd.sasldb and attempting to log in with both, the ones
> listed in /etc/sasldb2 worked.
> This looks exactly like I'm seeing, so I'm concerned that "--sasl-config" is
> broken on Ubuntu as is the path to the "default" qpidd.conf

Could this be https://issues.apache.org/jira/browse/QPID-3528? I.e. the 
usage statement is incorrect for that option - you actually need to set 
it to /etc/sasl2/ in your case (i.e. the path not the file itself)?

Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org

View raw message