predictionio-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From emergentor...@apache.org
Subject [predictionio] branch develop updated: Bump patch versions for akka and hadoop (#490)
Date Sat, 27 Oct 2018 20:41:58 GMT
This is an automated email from the ASF dual-hosted git repository.

emergentorder pushed a commit to branch develop
in repository https://gitbox.apache.org/repos/asf/predictionio.git


The following commit(s) were added to refs/heads/develop by this push:
     new 70eb7cd  Bump patch versions for akka and hadoop (#490)
70eb7cd is described below

commit 70eb7cd4c1099a61f42097f36ad143e0b76ce454
Author: Alex Merritt <lecaran@gmail.com>
AuthorDate: Sat Oct 27 15:41:54 2018 -0500

    Bump patch versions for akka and hadoop (#490)
    
    * Bump patch versions for akka and hadoop
    
    * Use gitbox for developerConnection
    
    * Fix LICENSE
    
    * Bump akka minor version; fix developerConnection
    
    * Fix LICENSE
---
 .travis.yml                                              |  8 ++++----
 LICENSE.txt                                              |  4 +---
 build.sbt                                                | 16 ++++++++--------
 conf/pio-vendors.sh                                      |  2 +-
 .../manual/source/install/install-sourcecode.html.md.erb |  4 ++--
 5 files changed, 16 insertions(+), 18 deletions(-)

diff --git a/.travis.yml b/.travis.yml
index 2a756e9..42662de 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -85,22 +85,22 @@ env:
       METADATA_REP=PGSQL EVENTDATA_REP=PGSQL MODELDATA_REP=PGSQL
       PIO_SCALA_VERSION=2.11.12
       PIO_SPARK_VERSION=2.0.2
-      PIO_HADOOP_VERSION=2.7.3
+      PIO_HADOOP_VERSION=2.7.7
     - BUILD_TYPE=Integration
       METADATA_REP=PGSQL EVENTDATA_REP=PGSQL MODELDATA_REP=PGSQL
       PIO_SCALA_VERSION=2.11.12
       PIO_SPARK_VERSION=2.1.3
-      PIO_HADOOP_VERSION=2.7.3
+      PIO_HADOOP_VERSION=2.7.7
     - BUILD_TYPE=Integration
       METADATA_REP=PGSQL EVENTDATA_REP=PGSQL MODELDATA_REP=PGSQL
       PIO_SCALA_VERSION=2.11.12
       PIO_SPARK_VERSION=2.2.2
-      PIO_HADOOP_VERSION=2.7.3
+      PIO_HADOOP_VERSION=2.7.7
     - BUILD_TYPE=Integration
       METADATA_REP=PGSQL EVENTDATA_REP=PGSQL MODELDATA_REP=HDFS
       PIO_SCALA_VERSION=2.11.12
       PIO_SPARK_VERSION=2.3.2
-      PIO_HADOOP_VERSION=2.7.3
+      PIO_HADOOP_VERSION=2.7.7
 
     - BUILD_TYPE=LicenseCheck
 
diff --git a/LICENSE.txt b/LICENSE.txt
index c83c231..6e02f9b 100644
--- a/LICENSE.txt
+++ b/LICENSE.txt
@@ -1356,8 +1356,6 @@ Binary distribution bundles
 Binary distribution bundles
 
   org.slf4j # slf4j-api # 1.7.25 (https://www.slf4j.org/)
-  org.slf4j # slf4j-api # 1.7.18 (https://www.slf4j.org/)
-  org.slf4j # slf4j-api # 1.7.16 (https://www.slf4j.org/)
   org.slf4j # slf4j-api # 1.7.10 (https://www.slf4j.org/)
   org.slf4j # slf4j-api # 1.7.2 (https://www.slf4j.org/)
   org.slf4j # slf4j-log4j12 # 1.7.18 (https://www.slf4j.org/)
@@ -1669,7 +1667,7 @@ DAMAGE.
 --------------------------------------------------------------------------------
 Binary distribution bundles
 
-  com.jcraft # jsch # 0.1.42 (http://www.jcraft.com/jsch/)
+  com.jcraft # jsch # 0.1.54 (http://www.jcraft.com/jsch/)
 
   which is available under the BSD license (http://www.jcraft.com/jsch/LICENSE.txt)
   
diff --git a/build.sbt b/build.sbt
index 5027fd9..9efed21 100644
--- a/build.sbt
+++ b/build.sbt
@@ -19,20 +19,20 @@ import PIOBuild._
 lazy val scalaSparkDepsVersion = Map(
   "2.11" -> Map(
     "2.0" -> Map(
-      "akka" -> "2.4.17",
-      "hadoop" -> "2.7.3",
+      "akka" -> "2.5.16",
+      "hadoop" -> "2.7.7",
       "json4s" -> "3.2.11"),
     "2.1" -> Map(
-      "akka" -> "2.4.17",
-      "hadoop" -> "2.7.3",
+      "akka" -> "2.5.17",
+      "hadoop" -> "2.7.7",
       "json4s" -> "3.2.11"),
     "2.2" -> Map(
-      "akka" -> "2.4.17",
-      "hadoop" -> "2.7.3",
+      "akka" -> "2.5.17",
+      "hadoop" -> "2.7.7",
       "json4s" -> "3.2.11"),
     "2.3" -> Map(
-      "akka" -> "2.4.17",
-      "hadoop" -> "2.7.3",
+      "akka" -> "2.5.17",
+      "hadoop" -> "2.7.7",
       "json4s" -> "3.2.11")))
 
 name := "apache-predictionio-parent"
diff --git a/conf/pio-vendors.sh b/conf/pio-vendors.sh
index f657a7c..d68ff7e 100644
--- a/conf/pio-vendors.sh
+++ b/conf/pio-vendors.sh
@@ -28,7 +28,7 @@ if [ -z "$PIO_SPARK_VERSION" ]; then
 fi
 
 if [ -z "$PIO_HADOOP_VERSION" ]; then
-    PIO_HADOOP_VERSION="2.7.3"
+    PIO_HADOOP_VERSION="2.7.7"
 fi
 
 if [ -z "$PIO_ELASTICSEARCH_VERSION" ]; then
diff --git a/docs/manual/source/install/install-sourcecode.html.md.erb b/docs/manual/source/install/install-sourcecode.html.md.erb
index 91a9a3d..9a1e456 100644
--- a/docs/manual/source/install/install-sourcecode.html.md.erb
+++ b/docs/manual/source/install/install-sourcecode.html.md.erb
@@ -29,7 +29,7 @@ building against
 
 * Scala 2.11.8
 * Spark 2.1.1
-* Hadoop 2.7.3
+* Hadoop 2.7.7
 * Elasticsearch 5.6.9
 
 Download [binary release from an Apache
@@ -104,7 +104,7 @@ Apache PredictionIO®. By default, the build will be against
 
 * Scala 2.11.8
 * Spark 2.1.1
-* Hadoop 2.7.3
+* Hadoop 2.7.7
 * Elasticsearch 5.6.9
 
 ```


Mime
View raw message