perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <>
Subject Re: OBSD update
Date Tue, 06 May 2003 03:45:58 GMT
Philippe M. Chiasson wrote:

> Well, you did just beat me to the punch ! I have been spending the last
> few days battling the OpenBSD build and was preparing to send out my
> SUCCESS story.

Great work, Philippe. I'll comment on the patch in a separate email.

Unfortunately OpenBSD 2.9 still doesn't work with your patch. Here is the 
segfault and how to reproduce it:



file /data/stas/httpd/prefork/bin/httpd
handle SIGPIPE nostop
handle SIGPIPE pass
set auto-solib-add 0
run -d `pwd`/t -f `pwd`/t/conf/httpd.conf -DONE_PROCESS -DNO_DETATCH -DAPACHE2

#0  0x40340296 in Perl_report_uninit ()
#1  0x40340aa5 in Perl_sv_upgrade ()
#2  0x4033549b in Perl_newHV ()
#3  0x402e929a in perl_construct ()
#4  0x402bf4e4 in modperl_startup (s=0x1cdd28, p=0x183018) at mod_perl.c:166
#5  0x402c07dc in modperl_init (base_server=0x1cdd28, p=0x183018) at 
#6  0x402c0998 in modperl_hook_init (pconf=0x183018, plog=0x0, ptemp=0x0, 
     at mod_perl.c:486
#7  0x402c09d4 in modperl_run () at mod_perl.c:497
#8  0x402c5032 in modperl_cmd_load_module (parms=0xdfbfda5c, mconfig=0x1d63c8,
     arg=0x1e34e8 "TestDirective::perlloadmodule3") at modperl_cmd.c:499
#9  0x7d7b2 in L413 () at config.c:713
#10 0x7e4c1 in ap_walk_config_sub (current=0x1e34c8, parms=0xdfbfda5c,
     section_vector=0x1cfbd8) at config.c:1082
#11 0x7e545 in ap_walk_config (current=0x1d6688, parms=0xdfbfda5c, 
     at config.c:1121
#12 0x7f2d4 in ap_process_config_tree (s=0x1cdd28, conftree=0x1d6688, p=0x183018,
     ptemp=0x187018) at config.c:1594
#13 0x83066 in L67 () at main.c:638

Did you have the same segfault before you managed to make it work?

> 1. On my machine, by default, the max file descriptors is set to 64, and
> it's not sufficient, 128 did it.

how do I change it on OpenBSD? that's the only thing that I haven't tried yet.

> 5. LD_LIBRARY_PATH. This one is the only one I don't understand quite
> yet. By default, it's set to /usr/local/lib:/usr/X11R6/lib on my
> machine. And the perl that ships with my OpenBSD will simply segfault in
> a completely bogus way:
> (gdb) bt
> #0  0x400078cf in end ()
> #1  0x40013060 in end ()
> #2  0x400074a8 in end ()
> #3  0x40007182 in end ()
> #4  0x400085bd in end ()
> The secret to fixing it for me so far, has been to make sure
> /usr/X11R6/lib isn't in my LD_LIBRARY_PATH. At this point, all attempts
> to figure out WHY have failed miserably.

You have to specify it explicitly when you invoke your mod_perl. We probably 
should supply a support for this from within Apache::Test.

Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker     mod_perl Guide --->

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message