openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter kovacs <pe...@apache.org>
Subject Re: AOO 4.1.6-RC1 m1 r1844555
Date Fri, 26 Oct 2018 22:51:50 GMT
Yes I applied them manually. And I took only changes from the version that I thought the change
is about.

Am 27. Oktober 2018 00:22:55 MESZ schrieb Don Lewis <truckman@apache.org>:
>On 27 Oct, Matthias Seidel wrote:
>> Am 27.10.18 um 00:10 schrieb Don Lewis:
>>> On 27 Oct, Matthias Seidel wrote:
>>>> Am 26.10.18 um 21:39 schrieb Don Lewis:
>>>>> On 26 Oct, Jim Jagielski wrote:
>>>>>>> On Oct 26, 2018, at 2:30 PM, Don Lewis <truckman@apache.org>
>wrote:
>>>>>>>
>>>>>>> The redland/raptor/rasqal upgrade
>>>>>>> https://bz.apache.org/ooo/show_bug.cgi?id=127887 got backed out.
>>>>>>> Someone with a Mac needs to see if the configure.in changes are
>needed
>>>>>>> or if it builds on a Mac as-is.
>>>>> When we upgraded those in trunk, it broke the Mac build.  You
>committed
>>>>> this change
>https://svn.apache.org/viewvc?view=revision&revision=1805089
>>>>> to unbreak things on the Mac, which include some changes to
>>>>> configure.ac.  AOO416 has configure.in instead of configure.ac, so
>in my
>>>>> instructions for merging this upgrade back to AOO416 here:
>>>>> https://bz.apache.org/ooo/show_bug.cgi?id=127887 I said to hand
>apply
>>>>> the configure.ac changes to configure.in.  That broke the buildbot
>>>>> builds at the configure stage due to shell syntax errors:
>>>>>
>https://ci.apache.org/builders/openoffice-linux64-41x/builds/159/steps/configure/logs/stdio
>>>>> so the entire upgrade was backed out of AOO416 with r1843571.
>>>>>
>>>>> The question is whether we can merge the four commits from trunk
>to
>>>>> AOO416 and skip the configure changes and get a successful build
>on the
>>>>> Mac, or do we need to do some other change to configure.in to get
>a
>>>>> successful build.  My testing without any configure.in changes
>worked on
>>>>> Linux and Windows.
>>>> I am building for Windows at the moment (omitting the changes in
>>>> configure.in).
>>>>
>>>> No problems so far...
>>> As I previously mentioned, I built and tested that on both Windows
>and
>>> Linux, specifically CentOS 6.  I didn't test CentOS 5 since my VM
>broke
>>> and it's difficult to set up a new CentOS 5 VM since that release
>has
>>> been archived.
>> 
>> So macOS remains to be tested...
>> 
>> I am not sure now what caused the buildbots to break, but they all
>> stopped early in configure.
>
>I think it was the step where the configure.ac changes for the Mac were
>manually applied to configure.in.  It is unclear whether they are
>actually required for the Mac or if they need to be reworked for
>configure.in.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>For additional commands, e-mail: dev-help@openoffice.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message