openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@apache.org>
Subject Re: Windows build woes
Date Tue, 08 Aug 2017 16:26:01 GMT
I ran into this same error as well when I did an incremental build
starting from expat.  Cleaning and doing a full build worked.

On  8 Aug, Patricia Shanahan wrote:
> Regardless of anything else you do, retry the full build, without 
> cleaning but also without specifying starting from the failure.
> 
> Sometimes the windows builds don't seem to get all the dependency 
> ordering right. If that is the cause of the failure, repeating the build 
> can resolve it. For example, my last windows build of 4.1.4 took three 
> tries.
> 
> 
> On 8/8/2017 8:16 AM, Jim Jagielski wrote:
>> Getting errors when building under Win7:
>> 
>> [ build RES ] apr-util/default
>> [ build RES ]
>> R=c:/cygwin/home/jim/src/asf/aoo-414 && O=$R/main/solver/414/wntmsci12 &&
W=$R/main/solver/414/wntmsci12/workdir && S=$R/main &&  $O/bin/makedepend.exe
-I. -IC:/cygwin$O/inc/stl -IC:/cygwin$O/inc/external -IC:/cygwin$O/inc -IC:/cygwin$S/solenv/wntmsci12/inc
-IC:/cygwin$S/solenv/inc -IC:/cygwin$S/res -IC:/AOO41X~1/OPENJD~1.0_U/include/win32 -IC:/AOO41X~1/OPENJD~1.0_U/include
-IC:/MICROS~1/Windows/v7.0/include -IC:/PROGRA~2/MICROS~1.0/VC/include -IC:/AOO41X~1/dxsdk/include
-IC:/AOO41X~1/dxsdk/include  -DWINVER=0x0400 -DWIN32  -DADDITIONAL_VERINFO1 -DADDITIONAL_VERINFO2
-DADDITIONAL_VERINFO3  $W/Dep/WinResTarget/apr-util/default.d -f - | awk -f C:/cygwin$S/solenv/gbuild/processdeps.awk
-v OBJECTFILE=$W/WinResTarget/apr-util/default.res -v OUTDIR=$O/ -v WORKDIR=$W/ -v SRCDIR=$S/
-v REPODIR=$R/ > $W/Dep/WinResTarget/apr-util/default.d
>> awk: fatal: can't open source file `C:/cygwinc:/cygwin/home/jim/src/asf/aoo-414/main/solenv/gbuild/processdeps.awk'
for reading (No such file or directory)
>> make: *** [C:/cygwin/home/jim/src/asf/aoo-414/main/solenv/gbuild/WinResTarget.mk:60:
/home/jim/src/asf/aoo-414/main/solver/414/wntmsci12/workdir/WinResTarget/apr-util/default.res]
Error 2
>> dmake:  Error code 2, while making './wntmsci12/misc/build/so_built_aprutil'
>> 
>> 1 module(s):
>>          apr-util
>> need(s) to be rebuilt
>> 
>> Reason(s):
>> 
>> ERROR: error 65280 occurred while making /home/jim/src/asf/aoo-414/ext_libraries/apr-util
>> 
>> When you have fixed the errors in that module you can resume the build by running:
>> 
>>          build --from apr-util
>> 
>> awk is gawk as required... The filename 'C:/cygwinc:/cygwin/home/jim/src/asf/aoo-414/main/solenv/gbuild/processdeps.awk'
>> look wonky as crud.
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>> For additional commands, e-mail: dev-help@openoffice.apache.org
>> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message