openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yemelyanenko Fyodor <fyodo...@hotmail.com>
Subject RE: Building OO
Date Thu, 20 Jul 2017 11:28:53 GMT
I also tried to build it with almost the same config as Damjan has.

SDK_PATH="/cygdrive/c/W7sdk/v7.0"

./configure \
--with-frame-home="$SDK_PATH" \
--with-psdk-home="$SDK_PATH" \
--with-midl-path="$SDK_PATH/bin" \
--with-ant-home="/cygdrive/c/ant" \
--with-dmake-url="http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2" \
--with-epm-url="http://www.msweet.org/files/project2/epm-3.7-source.tar.gz" \
--enable-pch \
--disable-atl \
--disable-activex \
--with-junit="/cygdrive/c/source/junit-4.12.jar" \
--with-hamcrest-core="/cygdrive/c/source/hamcrest-core-1.3.jar" \
--with-cl-home="/cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC" \
--with-csc-path="/cygdrive/c/Windows/Microsoft.NET/Framework/v3.5" \
--with-jdk-home="/cygdrive/c/Program Files/Java/jdk1.8.0_131" \
--disable-directx \
--with-package-format="installed" \
--enable-wiki-publisher

I have ant 1.10.1 and newer JDK from Oracle website.
I'll try to remove 1.8 JDK and install 1.7 JDK to make my config even more closer to one,
which builds successfully.
I think I misconfigured some prerequisite, and this is not error in code.

-----Original Message-----
From: Damjan Jovanovic [mailto:damjan@apache.org] 
Sent: Thursday, July 20, 2017 8:35 PM
To: Apache OO <dev@openoffice.apache.org>
Subject: Re: Building OO

Hi Matthias

As I posted earlier in this thread, this is how I build it:
32 bit VirtualBox VM
Windows XP
SDK_PATH="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0"
./configure --with-frame-home="$SDK_PATH" --with-psdk-home="$SDK_PATH"
--with-midl-path="$SDK_PATH/bin" --with-ant-home="/cygdrive/c/apache-ant-1.9.6"
--with-dmake-url="http://dmake.apache-extras.org.
codespot.com/files/dmake-4.12.tar.bz2" --with-epm-url="http://www.
msweet.org/files/project2/epm-3.7-source.tar.gz" --enable-pch --disable-atl --disable-activex
--with-junit="/cygdrive/c/source/junit.jar"
--with-hamcrest-core="/cygdrive/c/source/hamcrest.jar"
--with-cl-home="/cygdrive/c/Program Files/Microsoft Visual Studio 9.0/VC"
--with-csc-path="/cygdrive/c/Windows/Microsoft.NET/Framework/v3.5"
--with-jdk-home="/cygdrive/c/Program Files/Java/jdk1.7.0" --disable-directx --with-package-format="installed"
--enable-wiki-publisher

Please let us know what you find.

Regards
Damjan

On Thu, Jul 20, 2017 at 12:26 PM, Matthias Seidel < matthias.seidel@hamburg.de> wrote:

> Hi Damjan,
>
> Since I am not the only one with these errors, wouldn't it be easier 
> if you tell us your configuration and let us see what is different?
> I know the Windows buildbot could build from trunk (when it was
> functional) , but I see no real difference in the configuration.
>
> I think we are all following the steps described here:
>
> https://wiki.openoffice.org/wiki/Documentation/Building_
> Guide_AOO/Step_by_step#Windows_7.2C_Windows_8.1.2C_Windows_10
>
> If you do something different, could you update the Wiki?
>
> Regards, Matthias
>
>
> Am 20.07.2017 um 12:13 schrieb Damjan Jovanovic:
> > Since I am the main gbuild developer and Windows always builds for 
> > me,
> and
> > I cannot reproduce your problem, I only see the following solution.
> >
> > svn log -v > /path/to/log.txt
> > (so you have an offline log.txt for easy future reference) Look 
> > through log.txt, go to early 2015 or so.
> > Find a revision you want to try, and switch to it and try build it. 
> > I
> think
> > it was:
> > svn update -r <revision>
> > then clean the tree and try build.
> >
> > When you find a revision that builds that way, do the equivalent of 
> > "git bisect" between that revision and the latest revision, ie. go 
> > to a
> revision
> > about halfway between then and now, "svn update -r ..." and build, 
> > and
> keep
> > bisecting until you find the last working revision, then post the
> details.
> >
> > It will probably take a long time, and a dozen or so attempted 
> > builds,
> but
> > once you find it, it should allow us to narrow down the problem and
> figure
> > out what went wrong.
> >
> > Damjan
> >
> > On Thu, Jul 20, 2017 at 11:11 AM, Matthias Seidel < 
> > matthias.seidel@hamburg.de> wrote:
> >
> >> Hi,
> >>
> >> When building trunk (on Windows) I get exactly the same errors...
> >>
> >> Branch 414 builds just fine (with Java 7):
> >> https://home.apache.org/~mseidel/AOO-builds/AOO-414-Test/
> >>
> >> Regards, Matthias
> >>
> >>
> >> Am 20.07.2017 um 04:56 schrieb Yemelyanenko Fyodor:
> >>> I’ve took another try to build OO on W7 x32 But got same errors, 
> >>> as on W8 x64 May be I missed some prerequisites?
> >>>
> >>> Errors are in modules gtest, xml2cmp, salhelper, udm Cygwin seems 
> >>> to have bug on Windows as it only  shows full error text
> >> when resized to some size… So path to missed file is not full.
> >>> The gtest.h is in place, why gb_Deliver_deliver cannot find it?
> >>>
> >>> $ build --all:gtest
> >>> build -- version: 1775979
> >>>
> >>>
> >>> =============
> >>> Building module gtest
> >>> =============
> >>>
> >>> Entering /cygdrive/c/source/aoo-trunk/ext_libraries/gtest
> >>>
> >>> mkdir: cannot create directory './wntmsci12.pro/misc/build/
> gtest-1.7.0/':
> >> File exists
> >>> C:/source/aoo-trunk/main/solenv/gbuild/Package.mk:28: ***
> >> gb_Deliver_deliver: file does not exist in solver, and cannot be deli.
> >> Stop.nk/main/solver/420/wntmsci12.pro/inc/gtest/gtest.h
> >>> dmake:  Error code 2, while making './wntmsci12.pro/misc/build/
> >> so_built_oo_gtest'
> >>> 1 module(s):
> >>>         gtest
> >>> need(s) to be rebuilt
> >>>
> >>> Reason(s):
> >>>
> >>> ERROR: error 65280 occurred while making 
> >>> /cygdrive/c/source/aoo-trunk/
> >> ext_libraries/gtest
> >>> When you have fixed the errors in that module you can resume the 
> >>> build
> >> by running:
> >>>         build --all:gtest
> >>>
> >>> The sal helper cannot open include file conditn.h
> >>>
> >>> =============
> >>> Building module salhelper
> >>> =============
> >>>
> >>> Entering /cygdrive/c/source/aoo-trunk/main/salhelper/source
> >>>
> >>> mkout -- version: 1.8
> >>> Making:    all_salhelper.dpslo
> >>> Compiling: salhelper/wntmsci12.pro/misc/salhelper3MSC_version.c
> >>> Compiling: salhelper/source/condition.cxx
> >>> ../inc\salhelper/condition.hxx(29) : fatal error C1083: Cannot 
> >>> open
> >> include file: 'osl/conditn.h': No such file or directory
> >>> dmake:  Error code 2, while making 
> >>> '../wntmsci12.pro/slo/condition.obj
> '
> >>>
> >>> 1 module(s):
> >>>         salhelper
> >>> need(s) to be rebuilt
> >>>
> >>> Reason(s):
> >>>
> >>> ERROR: error 65280 occurred while making 
> >>> /cygdrive/c/source/aoo-trunk/
> >> main/salhelper/source
> >>> When you have fixed the errors in that module you can resume the 
> >>> build
> >> by running:
> >>>         build --all:salhelper
> >>>
> >>>
> >>>
> >>> From: Yemelyanenko Fyodor [mailto:fyodor_e@hotmail.com]
> >>> Sent: Wednesday, July 19, 2017 10:51 AM
> >>> To: Damjan Jovanovic <damjan@apache.org>; Apache OO <
> >> dev@openoffice.apache.org>
> >>> Subject: Re[5]: Building OO
> >>>
> >>> Hello!
> >>>
> >>> I've switched to Ubuntu 14.04 mini with xubuntu-desktop and xrdp
> >> installed
> >>> And OO built successfully! :-)
> >>>
> >>> Now trying to do the same on W7 x32.
> >>>
> >>> As Id like to deep dive into OO development, could you please 
> >>> share
> what
> >> dev environment do you use on Ubuntu and on W7 (I believe, that 
> >> I'll finally success in building OO on Windows).
> >>> Any thoughts on establishing dev environment will be appreciated.
> >>>
> >>> --
> >>> Fyodor
> >>>
> >>> ------ Исходное сообщение ------
> >>> От: "Емельяненко Федор" <fyodor_e@hotmail.com<mailto:f
> >> yodor_e@hotmail.com>>
> >>> Кому: "Damjan Jovanovic" 
> >>> <damjan@apache.org<mailto:damjan@apache.org>>
> >>> Копия: "Apache OO" <dev@openoffice.apache.org<mailto:
> >> dev@openoffice.apache.org>>
> >>> Отправлено: 04.07.2017 12:57:52
> >>> Тема: Re[4]: Building OO
> >>>
> >>> I use following config script
> >>>
> >>> ./configure \
> >>>    --with-frame-home="$SDK_PATH" \
> >>>    --with-psdk-home="$SDK_PATH" \
> >>>    --with-midl-path="$SDK_PATH/bin" \
> >>>    --with-ant-home="/cygdrive/c/ant110/apache-ant-1.10.1" \
> >>>    --with-jdk-home="C:/PROGRA~2/Java/JDK18~1.0_1" \
> >>>    --with-csc-path="C:/Windows/Microsoft.NET/Framework/v3.5" \
> >>>    --with-cl-home="C:/PROGRA~2/MICROS~1.0/VC" \
> >>>    --with-asm-home="C:/PROGRA~2/MICROS~1.0/VC/bin" \
> >>>    --with-dmake-url="https://sourceforge.net/projects/
> >> oooextras.mirror/files/dmake-4.12.tar.bz2" \
> >>>    --with-epm-url="https://sourceforge.net/projects/
> >> oooextras.mirror/files/epm-3.7.tar.gz" \
> >>>    --disable-pch \
> >>>    --disable-atl \
> >>>    --disable-activex \
> >>>    --disable-nss-module \
> >>>    --without-junit \
> >>>    --disable-directx
> >>>
> >>> On Windows 8.1 64 bit Hyper-v VM
> >>>
> >>> Full jdk path C:\Program Files (x86)\Java\jdk1.8.0_131 CL home 
> >>> C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC Asm home 
> >>> C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin
> >>>
> >>> I've tried to rebuild with following script (full path) with no 
> >>> success
> >>>
> >>> ./configure \
> >>>    --with-frame-home="$SDK_PATH" \
> >>>    --with-psdk-home="$SDK_PATH" \
> >>>    --with-midl-path="$SDK_PATH/bin" \
> >>>    --with-ant-home="/cygdrive/c/ant110/apache-ant-1.10.1" \
> >>>    --with-jdk-home="/cygdrive/c/Program Files
> (x86)/Java/jdk1.8.0_131" \
> >>>    --with-csc-path="/cygdrive/c/Windows/Microsoft.NET/Framework/v3.5"
> \
> >>>    --with-cl-home="/cygdrive/c/Program Files (x86)/Microsoft 
> >>> Visual
> >> Studio 9.0/VC" \
> >>>    --with-asm-home="/cygdrive/c/Program Files (x86)/Microsoft 
> >>> Visual
> >> Studio 9.0/VC/bin" \
> >>>    --with-dmake-url="https://sourceforge.net/projects/
> >> oooextras.mirror/files/dmake-4.12.tar.bz2" \
> >>>    --with-epm-url="https://sourceforge.net/projects/
> >> oooextras.mirror/files/epm-3.7.tar.gz" \
> >>>    --disable-pch \
> >>>    --disable-atl \
> >>>    --disable-activex \
> >>>    --disable-nss-module \
> >>>    --without-junit \
> >>>    --disable-directx
> >>>
> >>> Now I have error on module gtest...
> >>>
> >>> dmake: Error code 2, while making './wntmsci12.pro/misc/build/
> >> so_built_oo_gtest'
> >>> 1 module(s):
> >>> gtest
> >>> need(s) to be rebuilt
> >>>
> >>> Reason(s):
> >>>
> >>> ERROR: error 65280 occurred while making 
> >>> /cygdrive/c/source/aoo-trunk/
> >> ext_libraries/gtest
> >>> When you have fixed the errors in that module you can resume the 
> >>> build
> >> by running:
> >>> build --all:gtest
> >>>
> >>> ------ Исходное сообщение ------
> >>> От: "Damjan Jovanovic" 
> >>> <damjan@apache.org<mailto:damjan@apache.org>>
> >>> Кому: "Yemelyanenko Fyodor" <fyodor_e@hotmail.com<mailto:f
> >> yodor_e@hotmail.com>>
> >>> Копия: "Apache OO" <dev@openoffice.apache.org<mailto:
> >> dev@openoffice.apache.org>>
> >>> Отправлено: 02.07.2017 16:46:09
> >>> Тема: Re: Re[2]: Building OO
> >>>
> >>> I just succeeded in building trunk with:
> >>> 32 bit VirtualBox VM
> >>> Windows XP
> >>> SDK_PATH="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0"
> >> ./configure --with-frame-home="$SDK_PATH" --with-psdk-home="$SDK_PATH"
> >> --with-midl-path="$SDK_PATH/bin" --with-ant-home="/cygdrive/c/
> apache-ant-1.9.6"
> >> --with-dmake-url="http://dmake.apache-extras.org.
> >> codespot.com/files/dmake-4.12.tar.bz2" --with-epm-url="http://www.
> >> msweet.org/files/project2/epm-3.7-source.tar.gz" --enable-pch 
> >> --disable-atl --disable-activex --with-junit="/cygdrive/c/
> source/junit.jar"
> >> --with-hamcrest-core="/cygdrive/c/source/hamcrest.jar"
> >> --with-cl-home="/cygdrive/c/Program Files/Microsoft Visual Studio
> 9.0/VC"
> >> --with-csc-path="/cygdrive/c/Windows/Microsoft.NET/Framework/v3.5"
> >> --with-jdk-home="/cygdrive/c/Program Files/Java/jdk1.7.0"
> >> --disable-directx --with-package-format="installed"
> >> --enable-wiki-publisher
> >>> Please post your full setup and build options.
> >>> Regards
> >>> Damjan
> >>>
> >>> On Fri, Jun 30, 2017 at 7:37 AM, Yemelyanenko Fyodor <
> >> fyodor_e@hotmail.com<mailto:fyodor_e@hotmail.com>> wrote:
> >>> Hello Damjan,
> >>>
> >>> I've commented out in main/udm/StaticLibrary_udm.mk
> >>>
> >>> #ifeq ($(OS),WNT)
> >>> #$(eval $(call gb_StaticLibrary_add_cflags,udm,-GR))
> >>> #else
> >>>
> >>> Now build stopped on xml2cmp module...
> >>>
> >>>
> >>>                         =============
> >>>                         Building module xml2cmp
> >>>                         =============
> >>>
> >>>                         Entering /cygdrive/c/source/aoo-trunk/
> >> main/xml2cmp/prj
> >>>                         cd .. && make -s -r -j1   && make
-s -r
> >> deliverlog
> >>>                         [ info  ALL ] LinkTarget 
> >>> Library/msvcprt.lib
> not
> >> defined: Assuming
> >>> headers to be there!
> >>>                         [ info  ALL ] LinkTarget 
> >>> Library/kernel32.lib
> >> not defined: Assuming
> >>> headers to be there!
> >>>                         [ info  ALL ] LinkTarget 
> >>> Library/msvcrt.lib not
> >> defined: Assuming
> >>> headers to be there!
> >>>                         [ info  ALL ] LinkTarget 
> >>> Library/oldnames.lib
> >> not defined: Assuming
> >>> headers to be there!
> >>>                         [ build CXX ] xml2cmp/source/finder/dependy
> >>>                         dependy.cxx
> >>>                         [ build CXX ] xml2cmp/source/finder/dep_main
> >>>                         dep_main.cxx
> >>>                         [ build CXX ] xml2cmp/source/xcd/cr_html
> >>>                         cr_html.cxx
> >>>                         [ build CXX ] xml2cmp/source/xcd/cr_index
> >>>                         cr_index.cxx
> >>>                         [ build CXX ] xml2cmp/source/xcd/cr_metho
> >>>                         cr_metho.cxx
> >>>                         [ build CXX ] xml2cmp/source/xcd/filebuff
> >>>                         filebuff.cxx
> >>>                         [ build CXX ] xml2cmp/source/xcd/parse
> >>>                         parse.cxx
> >>>                         [ build CXX ] xml2cmp/source/xcd/xmlelem
> >>>                         xmlelem.cxx
> >>>                         [ build CXX ] xml2cmp/source/xcd/xmltree
> >>>                         xmltree.cxx
> >>>                         [ build CXX ] xml2cmp/source/support/cmdline
> >>>                         cmdline.cxx
> >>>                         [ build CXX ] xml2cmp/source/support/heap
> >>>                         heap.cxx
> >>>                         [ build CXX ] xml2cmp/source/support/sistr
> >>>                         sistr.cxx
> >>>                         [ build CXX ] xml2cmp/source/support/syshelp
> >>>                         syshelp.cxx
> >>>                         [ build CXX ] xml2cmp/source/support/badcast
> >>>                         badcast.cxx
> >>>                         [ build DEP ] LNK:Executable/srvdepy.exe
> >>>                         [ build CXX ] xml2cmp/source/xcd/main
> >>>                         main.cxx
> >>>                         [ build DEP ] LNK:Executable/xml2cmp.exe
> >>>                         ', needed by 
> >>> '/cygdrive/c/source/aoo-trunk/main/solver/420/wntmsci12.pro/
> >> workdir/CxxObject/xml2cmp/source/xcd/cr_html.o<http://
> >> wntmsci12.pro/workdir/CxxObject/xml2cmp/source/xcd/cr_html.o>'.
> >>>   Stop.
> >>>                         dmake:  Error code 2, while making 'all'
> >>>
> >>>                         1 module(s):
> >>>                                 xml2cmp
> >>>                         need(s) to be rebuilt
> >>>
> >>>                         Reason(s):
> >>>
> >>>                         ERROR: error 65280 occurred while making 
> >>> /cygdrive/c/source/aoo-trunk/main/xml2cmp/prj
> >>>
> >>>                         When you have fixed the errors in that 
> >>> module
> >> you can resume the
> >>> build by running:
> >>>
> >>>                                 build --all:xml2cmp
> >>>
> >>> ------ Исходное сообщение ------
> >>> От: "Damjan Jovanovic" 
> >>> <damjan@apache.org<mailto:damjan@apache.org>>
> >>> Кому: "Yemelyanenko Fyodor" <fyodor_e@hotmail.com<mailto:f
> >> yodor_e@hotmail.com>>
> >>> Копия: "Apache OO" <dev@openoffice.apache.org<mailto:
> >> dev@openoffice.apache.org>>
> >>> Отправлено: 28.06.2017 15:07:29
> >>> Тема: Re: Building OO
> >>>
> >>>> Hi Fyodor
> >>>>
> >>>> The problem is almost certainly in main/udm/StaticLibrary_udm.mk
> >>>>
> >>>> Make try take out the contents of the ifeq ($(OS),WNT) section?
> >>>>
> >>>> I'll try build it later.
> >>>>
> >>>> Damjan
> >>>>
> >>>> On Wed, Jun 28, 2017 at 6:00 AM, Yemelyanenko Fyodor 
> >>>> <fyodor_e@hotmail.com<mailto:fyodor_e@hotmail.com>> wrote:
> >>>>> Hi Damjan,
> >>>>>
> >>>>> I’ve got OO using svn co
> >>>>> https://svn.apache.org/repos/asf/openoffice/trunk
> >>>>> <https://svn.apache.org/repos/asf/openoffice/trunk> aoo-trunk
a 
> >>>>> week ago.
> >>>>>
> >>>>> I've cd'ed to udm and tried build -all:udm
> >>>>>
> >>>>> This is output
> >>>>>                         Admin@shr-pc 
> >>>>> /cygdrive/c/source/aoo-trunk/main/udm
> >>>>>                         $ build --all:udm
> >>>>>                         build -- version: 1775979
> >>>>>
> >>>>>
> >>>>>                         =============
> >>>>>                         Building module udm
> >>>>>                         =============
> >>>>>
> >>>>>                         Entering 
> >>>>> /cygdrive/c/source/aoo-trunk/main/udm/prj
> >>>>>
> >>>>>                         cd .. && make -s -r -j1   &&
make -s -r
> >>>>> deliverlog
> >>>>>                         ', needed by 
> >>>>> '/cygdrive/c/source/aoo-trunk/main/solver/420/wntmsci12.pro/
> >> workdir/CxxObject/udm/source/html/htmlitem.o<http://
> wntmsci12.pro/workdir/
> >> CxxObject/udm/source/html/htmlitem.o>
> >>>>> <http://wntmsci12.pro/workdir/CxxObject/udm/source/html/htmlitem
> >>>>> .o
> >'.
> >>>>>   Stop.
> >>>>>                         dmake:  Error code 2, while making 'all'
> >>>>>
> >>>>>                         1 module(s):
> >>>>>                                 udm
> >>>>>                         need(s) to be rebuilt
> >>>>>
> >>>>>                         Reason(s):
> >>>>>
> >>>>>                         ERROR: error 65280 occurred while making

> >>>>> /cygdrive/c/source/aoo-trunk/main/udm/prj
> >>>>>
> >>>>>                         When you have fixed the errors in that 
> >>>>> module you can resume the build by running:
> >>>>>
> >>>>>                                 build --all:udm
> >>>>>
> >>>>>
> >>>>> I think I need to deep dive into dmake, so I'll be able to trace
> build
> >>>>> and link processes and find what exactly done on udm module. So

> >>>>> I'll appreciate reference to information on dmake.
> >>>>>
> >>>>> --
> >>>>> Fyodor
> >>>>>
> >>>>>
> >>>>> From: Damjan Jovanovic [mailto:damjan@apache.org<mailto:
> >> damjan@apache.org>]
> >>>>> Sent: Tuesday, June 27, 2017 5:38 PM
> >>>>> To: Apache OO <dev@openoffice.apache.org<mailto:
> dev@openoffice.apache.
> >> org>>; fyodor_e@hotmail.com<mailto:fyodor_e@hotmail.com>
> >>>>> Subject: Re: Building OO
> >>>>>
> >>>>> Hi Fyodor
> >>>>> Welcome to AOO :).
> >>>>> What version are you building?
> >>>>> Can you "cd" into the udm directory, and post the full output of

> >>>>> "build"
> >>>>> run from there?
> >>>>> Thank you
> >>>>> Damjan
> >>>>>
> >>>>> On Tue, Jun 27, 2017 at 8:12 AM, Yemelyanenko Fyodor 
> >>>>> <fyodor_e@hotmail.com<mailto:fyodor_e@hotmail.com>>
wrote:
> >>>>> =============
> >>>>> Building module udm
> >>>>> =============
> >>>>>
> >>>>> Entering /cygdrive/c/source/aoo-trunk/main/udm/prj
> >>>>> Hello!
> >>>>>
> >>>>> I'm newbie in OO development, and as New Volunteer Orientation 
> >>>>> module suggests, I've established local build env, and try to build
OO.
> >>>>> I've installed required prerequisites from Building Guide 
> >>>>> (http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AO
> >>>>> O
> >>>>> <http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AO
> >>>>> O>)
> >>>>> and
> >>>>> started to build with this command
> >>>>>
> >>>>> ./configure \
> >>>>>      --with-frame-home="$SDK_PATH" \
> >>>>>      --with-psdk-home="$SDK_PATH" \
> >>>>>      --with-midl-path="$SDK_PATH/bin" \
> >>>>>      --with-ant-home="/cygdrive/c/ant110/apache-ant-1.10.1" \
> >>>>>      --with-jdk-home="C:/PROGRA~2/Java/JDK18~1.0_1" \
> >>>>>      --with-csc-path="C:/Windows/Microsoft.NET/Framework/v3.5" \
> >>>>>      --with-cl-home="C:/PROGRA~2/MICROS~1.0/VC" \
> >>>>>      --with-asm-home="C:/PROGRA~2/MICROS~1.0/VC/bin" \
> >>>>>
> >>>>> --with-dmake-url="https://sourceforge.net/projects/
> >> oooextras.mirror/files/dmake-4.12.tar.bz2
> >>>>> <https://sourceforge.net/projects/oooextras.mirror/
> >> files/dmake-4.12.tar.bz2>"
> >>>>> \
> >>>>>
> >>>>> --with-epm-url="https://sourceforge.net/projects/
> >> oooextras.mirror/files/epm-3.7.tar.gz
> >>>>> <https://sourceforge.net/projects/oooextras.mirror/
> >> files/epm-3.7.tar.gz>"
> >>>>> \
> >>>>>      --disable-pch \
> >>>>>      --disable-atl \
> >>>>>      --disable-activex \
> >>>>>      --disable-nss-module \
> >>>>>      --without-junit \
> >>>>>      --disable-directx
> >>>>>
> >>>>> There are some modules built successfully, but built stop on UDM

> >>>>> module with following error
> >>>>>
> >>>>> cd .. && make -s -r -j1   && make -s -r deliverlog
> >>>>> [ build CXX ] udm/source/html/htmlitem htmlitem.cxx [ build CXX

> >>>>> ] udm/source/xml/xmlitem xmlitem.cxx [ build DEP ] 
> >>>>> LNK:StaticLibrary/udm.lib [ build PKG ] udm_inc ', needed by 
> >>>>> '/cygdrive/c/source/aoo-trunk/main/solver/420/wntmsci12.pro/
> >> workdir/CxxObject/udm/source/html/htmlitem.o<http://
> wntmsci12.pro/workdir/
> >> CxxObject/udm/source/html/htmlitem.o>
> >>>>> <http://wntmsci12.pro/workdir/CxxObject/udm/source/html/htmlitem
> >>>>> .o
> >'.
> >>>>>   Stop.
> >>>>> dmake:  Error code 2, while making 'all'
> >>>>>
> >>>>> 1 module(s):
> >>>>>          udm
> >>>>> need(s) to be rebuilt
> >>>>>
> >>>>> Reason(s):
> >>>>>
> >>>>> ERROR: error 65280 occurred while making 
> >>>>> /cygdrive/c/source/aoo-trunk/main/udm/prj
> >>>>>
> >>>>> When you have fixed the errors in that module you can resume the
> build
> >>>>> by running:
> >>>>>
> >>>>>          build --all:udm
> >>>>>
> >>>>> I'm not professional with dmake (yet), so any help would be 
> >>>>> appreciated.
> >>>>>
> >>>>> --
> >>>>> Fyodor
> >>>>>
> >>>>>
> >>>>> ------------------------------------------------------------
> ---------
> >>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> <mailto:
> >> dev-unsubscribe@openoffice.apache.org>
> >>>>> <mailto:dev-unsubscribe@openoffice.apache.org<mailto:d
> >> ev-unsubscribe@openoffice.apache.org>>
> >>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
> >> <mailto:dev-help@openoffice.apache.org>
> >>
> >>
>
>
>
Mime
View raw message