openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Giehl <c.gi...@gmail.com>
Subject Eclipse Module Export UNO -> OOo package does not proceed
Date Wed, 06 Apr 2016 08:35:32 GMT
Hi,

I'm fairly new on the field and wanted to start developing an extension 
to be used in Writer. I started on reading the wiki and just tried to 
follow the tutorial here: https://wiki.openoffice.org/wiki/JavaEclipseTuto
Unfortunately when it comes to exporting the module in Eclipse File -> 
Export -> UNO -> OpenOffice.org package, nothing happens. From my pov I 
have two possibilities now: ask if sb can help troubleshoot or build the 
module somehow manually.
Since I am a beginner, I am not restricted in writing the extension in 
Java. Another possibility I considered is to write in python. I chose 
Java because it seemed to me the more stable and documented approach to 
get in touch. I'm free for suggestions regarding the language.

My system:
Win10 x64
OO 4.12.9782
OO SDK 4.12.9782
(note: OO installed with x86 instead of x64)

What I tried:
- reinstall of all features
- changed the eclipse plugin from 
(http://www.openoffice.org/api/Projects/EclipseIntegration/dev-update/site.xml) 
to (http://drake79.users.sourceforge.net/ooeclipse/site) due to the 
issue described here 
(http://stackoverflow.com/questions/17980315/openoffice-eclipse-plugin-doesnt-recognize-openoffice-sdk)
- reinstalled OO and removed the spaces in path (I saw a hint during 
installation stating that spaces in paths might break the build)

Disclaimer: I don't know whether this is the appropriate newsgroup to 
post such kind of questions. Please give hints if there might be a more 
suitable place. Please tell me if you need further info.

Thanks in advance!
Greetings


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message