openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carl Marcum <cmar...@apache.org>
Subject Re: [DISCUSS][VOTE] Release Groovy UNO Extension 0.1.4-RC2
Date Thu, 21 Apr 2016 22:12:35 GMT
On 04/21/2016 02:09 PM, Patricia Shanahan wrote:
> The .class files in the uploaded .jar were compiled with Java 1.8:
>
> Patricia@Jan2014Desktop 
> /cygdrive/c/Users/Patricia/.groovy/grapes/org.openoffice/guno-extension/jars
> $ !find
> find . -type f -name '*.class' -exec file '{}' ';' -print
> ./org/openoffice/guno/SpreadsheetExtension.class: compiled Java class 
> data, version 52.0 (Java 1.8)
> ./org/openoffice/guno/SpreadsheetExtension.class
> ./org/openoffice/guno/UnoExtension.class: compiled Java class data, 
> version 52.0 (Java 1.8)
> ./org/openoffice/guno/UnoExtension.class
>
> so Groovy will need a 1.8 JRE to run them.
>
> On 4/21/2016 10:47 AM, Patricia Shanahan wrote:
>> After some more testing: It works with JDK1.8 or JRE1.8, 32-bit or
>> 64-bit in each case.
>>
>> However, it fails with the following output using jdk1.7.0_79.
>>
Looks like I overlooked that.

If that gives people any issues I can add

|sourceCompatibility=  1.6
targetCompatibility=  1.6

to the gradle.build file to fix it and create a new RC.

Thanks,
Carl

|



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message