openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver-Rainer Wittmann <orwittm...@googlemail.com>
Subject Re: [discuss] drop support for Java 5 and Java 6 for Windows
Date Wed, 07 Aug 2013 10:27:17 GMT
Hi,

On 07.08.2013 12:13, Peter Eberlein wrote:
> Hi Oliver,
> Am 07.08.2013 09:44, schrieb Oliver-Rainer Wittmann:
>> Hi,
>>
>> I would like to discuss here, if we drop the support for Java 5 and Java
>> 6 for AOO installation on Windows.
>> Important note for discussion: it is all about platform Windows.
>>
>> On my work to update the AOO build environment for Windows I recognized
>> that it is hard to get an official JDK 1.5 (Java 5) or JDK 1.6 (Java 6)
>> for Windows. Thus, I decided to go with JDK 1.7. The resulting AOO
>> installation on Windows no longer works together with an JRE 6. It does
>> not recognize an installed JRE 6 as an valid Java runtime environment.
>> Thus, it comes into my mind to drop the support for Java 5 and Java 6
>> for Windows.
>>
>
> If Java 6 has been dropped and Java 7 wasn't found on the system,
> wouldn't it be better to replace the general MsgBox "There was no Java
> environment found" by "Java 7 or higher wasn't found"?
> Otherwise people who know that they have 1.6 installed may be confused.
>

I agree.
In case that we decide to drop support for Java 5 and Java 6 on Windows, 
the corresponding message should be adjusted for Windows.

Best regards, Oliver.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message