openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From the mad doctor kaeding <>
Subject Re: Re : change UI font size
Date Fri, 09 Sep 2011 21:18:13 GMT
The problem is that KDE has a setting called "force DPI" in
KControl > Appearance > Fonts.  If disabled, then KDE seems
to scale fonts to the /physical/ size requested, i.e. 72pt/in.
OO does not read this setting from KConfiguration, or ignores
it, and instead renders fonts with 1px = 1pt.  The result is an
ugly mismatch between KDE and OO apps.  I found a way
to work around it.

I use linux with very recent versions of GCC and binutils.
While building OO, several modules failed to link.  For example,
the sot module failed with this message:

../ In function `Reference':
undefined reference to `non-virtual thunk to
/usr/bin/ld: ../ relocation
R_X86_64_PC32 against undefined symbol `non-virtual thunk to
utl::OOutputStreamWrapper::acquire()' can not be used when making a
shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
dmake: Error code 1, while making '../'

There are about a dozen such failures.  I worked around them, but am
reporting them to you anyway.  I realize that noone is reading this
message, but don't worry:  I am unsubscribing today.  Good luck.

On 9/4/11, drew <> wrote:
> On Sun, 2011-09-04 at 13:32 -0400, the mad doctor kaeding wrote:
>> The users on the user list sent me to this (dev) list.
>> I use linux with KDE 3.5.  Un/selecting "use system font"
>> has no effect.  Adding font replacements has no effect.
>> I tried the scaling options, but they only affect the
>> document I am editing, not the UI.
>> Please tell me, where in the source code is the size of
>> the UI font set?
> Not sure on where in the code - but this type of thing often has one
> sure fire fix - kill the user configuration direction and when the
> application starts the next time it creates new, default settings.
> You should find that user config file at:
> <home>/.openoffice/user
> Just rename that directory with the application stopped and then start
> it up, should clear the problem.
> //drew
> <snip>

View raw message