openjpa-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MiƂosz Tylenda <mtyle...@o2.pl>
Subject Re: Two OpenJPA Applications in the same container
Date Sun, 07 Mar 2010 11:06:59 GMT
Hi,

Do your entities have the same class and package names in both applications? If so, I suspect
an issue with unified class loader in JBoss [1]. You might try configuring your applications
to use separate class loaders.

Let us know whether it helps.

Cheers,
Milosz

[1] http://community.jboss.org/wiki/ClassLoadingConfiguration



> Hi
> 
> I'm running two webapplications in the same JBOSS container.
> 
> They both access the same database and they access the same tables (there is
> an overlap)
> 
> The applications cannot eb combined into one application.
> 
> The problem now is, whichever application I access first after the JBOSS
> startup is the one that works, the other appliction doesn't load it's
> entities correctly and gives me errors like
> 
> An error occurred while parsing the query filter "select a from
> KycRequestBusinessContactPerson a where a.userName =?1". Error message: The
> name "KycRequestBusinessContactPerson" is not a recognized entity or
> identifier. Known entity names: []
> 
> It has no known entity names for the second application.
> 
> What's the correct way to have two applications access the same datasource
> using openjpa ?
> 
> -- 
> View this message in context: http://n2.nabble.com/Two-OpenJPA-Applications-in-the-same-container-tp4686242p4686242.html
> Sent from the OpenJPA Users mailing list archive at Nabble.com.
> 

Mime
View raw message