openjpa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Dick (JIRA)" <j...@apache.org>
Subject [jira] Commented: (OPENJPA-1921) Persist detached object error when using PROPERTY access instead of FIELD access
Date Mon, 10 Jan 2011 15:54:45 GMT

    [ https://issues.apache.org/jira/browse/OPENJPA-1921?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12979613#action_12979613
] 

Michael Dick commented on OPENJPA-1921:
---------------------------------------

The accessor methods for the version field use Integer, but the type of the field is int.
 If you change the accessor methods to use the primitive type you'll at least work around
the problem. 

> Persist detached object error when using PROPERTY access instead of FIELD access
> --------------------------------------------------------------------------------
>
>                 Key: OPENJPA-1921
>                 URL: https://issues.apache.org/jira/browse/OPENJPA-1921
>             Project: OpenJPA
>          Issue Type: Bug
>    Affects Versions: 2.0.1
>         Environment: Windows XP, JUnit test under Eclipse.
>            Reporter: Cyrille Charron
>         Attachments: FamilyModel.zip, HibernateTest.zip, OpenJPA-bug.txt
>
>
> When changing my orm.xml file to have access="PROPERTY" instead of access="FIELD", my
JUnit test fails with an EntityExistsException.
> Id of my entities are not generated, but set manually.
> I join 2 zip files of the Eclipse test project (1 for the entities, 1 for the test under
OpenEjb), and the stdout file with the error.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message