nifi-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jorge Machado <jom...@me.com>
Subject Multiple versions of .... exist.
Date Mon, 12 Mar 2018 07:46:31 GMT
Hello everyone, 

I we setting up the Nifi registry are we are getting this error when trying to import a flow
from Registry into Nifi: 

Multiple versions of …. exist. No exact match for default:...:unversioned.
To note that we have multiple versions of the same processor in the lib folder (which works
for Templates)
Our Manifest inside the nar file looks like this: 
Manifest-Version: 1.0
Implementation-Title: componentName
Implementation-Version: 1.5.9.rc.1
Nar-Dependency-Group: org.apache.nifi
Nar-Version: 1.5.9.rc.1
Nar-Dependency-Version: 1.5.0
Nar-Id: componentName
Nar-Group: com.componentName
Nar-Dependency-Id: nifi-standard-services-api-nar

I see this on the Nifi Logs: 
2018-03-12 08:33:51,304 INFO [NiFi Web Server-94] o.a.n.w.a.c.IllegalStateExceptionMapper
java.lang.IllegalStateException: Multiple versions of com.gfk.nifi.processor.customlogging.CustomLogger
exist. No exact match for default:ipmvp-nifi-customlogattribute:unversioned.. Returning Conflict
response.

Any Ideias ? 

Jorge






Mime
View raw message