nifi-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (Jira)" <j...@apache.org>
Subject [jira] [Commented] (NIFI-6028) Upgrading NiFi can put versioned flows into a conflict state
Date Tue, 03 Sep 2019 15:33:00 GMT

    [ https://issues.apache.org/jira/browse/NIFI-6028?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16921518#comment-16921518
] 

ASF subversion and git services commented on NIFI-6028:
-------------------------------------------------------

Commit 180a188096905ec3c599f45a4c0235778951fb7c in nifi's branch refs/heads/master from Bryan
Bende
[ https://gitbox.apache.org/repos/asf?p=nifi.git;h=180a188 ]

NIFI-6028 Protect against null VersionedComponent when finding relevant process group

This closes #3686.

Signed-off-by: Mark Payne <markap14@hotmail.com>


> Upgrading NiFi can put versioned flows into a conflict state
> ------------------------------------------------------------
>
>                 Key: NIFI-6028
>                 URL: https://issues.apache.org/jira/browse/NIFI-6028
>             Project: Apache NiFi
>          Issue Type: Bug
>    Affects Versions: 1.5.0, 1.6.0, 1.7.0, 1.8.0, 1.7.1
>            Reporter: Bryan Bende
>            Assignee: Mark Payne
>            Priority: Major
>              Labels: SDLC
>             Fix For: 1.10.0
>
>          Time Spent: 1h 20m
>  Remaining Estimate: 0h
>
> When you upgrade NiFi, existing processors may have new properties and relationships.
If any of those processors are part of a versioned flow then these changes will trigger a
local modification indicating that a new version needs to be saved to registry to track the
new properties or relationships.
> The issue is when you have multiple environments...
>  * Start in dev with NiFi version X
>  * Upgrade dev to NiFi version Y
>  * Now commit versioned PGs in dev that had local changes
>  * Go to staging and upgrade NiFi to version Y
>  * The versioned PGs are now in conflict because there is an upgrade available, but there
are local changes detected from upgrading NiFI, even though these are the same changes available
in the upgrade



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message