madlib-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nandish Jayaram <njaya...@pivotal.io>
Subject Re: [jira] [Created] (MADLIB-1198) Madpack upgrade from MADlib 1.12 to 1.13 fails on Greenplum 4.3.17
Date Fri, 12 Jan 2018 22:48:43 GMT
Hi Kyle,

Thank you for pointing this. We already noticed this issue and created
https://issues.apache.org/jira/browse/MADLIB-1197.
The workaround is available on the Wiki (
https://cwiki.apache.org/confluence/display/MADLIB/Installation+Guide#InstallationGuide-01/11/18-UpgradingMADlibto1.13
).
The PR for the fix is out there for review:
https://github.com/apache/madlib/pull/224

Thanks,
MADlib team

On Fri, Jan 12, 2018 at 2:32 PM, Kyle R Dunn (JIRA) <jira@apache.org> wrote:

> Kyle R Dunn created MADLIB-1198:
> -----------------------------------
>
>              Summary: Madpack upgrade from MADlib 1.12 to 1.13 fails on
> Greenplum 4.3.17
>                  Key: MADLIB-1198
>                  URL: https://issues.apache.org/jira/browse/MADLIB-1198
>              Project: Apache MADlib
>           Issue Type: Bug
>           Components: Madpack
>             Reporter: Kyle R Dunn
>
>
> I recently attempted to perform an upgrade from MADlib 1.12 to 1.13 on
> Greenplum 4.  The madpack upgrade process failed with the following output:
>
> {code}
> [gpadmin@gpdb4 ~]$ $GPHOME/madlib/bin/madpack upgrade -s madlib -p
> greenplum -c gpadmin@localhost:5432/infosecdb
> madpack.py: INFO : Detected Greenplum DB version 4.3.17.
> madpack.py: INFO : *** Upgrading MADlib ***
> madpack.py: INFO : MADlib tools version    = 1.13
> (/usr/local/greenplum-db-4.3.17/madlib/Versions/1.13/bin/..
> /madpack/madpack.py)
> madpack.py: INFO : MADlib database version = 1.12 (host=localhost:5432,
> db=infosecdb, schema=madlib)
> madpack.py: INFO : Testing PL/Python environment...
> madpack.py: INFO : > PL/Python environment OK (version: 2.6.9)
> madpack.py: INFO : Upgrading MADlib into MADLIB schema...
> madpack.py: INFO :      Detecting dependencies...
> madpack.py: INFO :      Loading change list...
> madpack.py: INFO :      Detecting table dependencies...
> madpack.py: INFO :      Detecting view dependencies...
> madpack.py: INFO : No dependency problem found, continuing to upgrade ...
> madpack.py: INFO : > Writing version info in MigrationHistory table
> madpack.py: INFO : > Creating/Updating objects for modules:
> madpack.py: INFO : > - array_ops
> madpack.py: INFO : > - bayes
> madpack.py: INFO : > - crf
> madpack.py: INFO : > - elastic_net
> madpack.py: INFO : > - linalg
> madpack.py: INFO : > - pmml
> madpack.py: INFO : > - prob
> madpack.py: INFO : > - sketch
> madpack.py: INFO : > - svec
> madpack.py: INFO : > - svm
> madpack.py: INFO : > - tsa
> madpack.py: INFO : > - stemmer
> madpack.py: INFO : > - conjugate_gradient
> madpack.py: INFO : > - knn
> madpack.py: ERROR : TEST CASE RESULTed executing
> /tmp/madlib.3O4Eb_/knn/knn.sql_in.tmp
> madpack.py: ERROR : Check the log at /tmp/madlib.3O4Eb_/knn/knn.sql_in.log
> Exception:
> (<type 'exceptions.Exception'>, Exception(), <traceback object at
> 0x2399830>)
>   File "/usr/local/greenplum-db-4.3.17/madlib/Versions/1.13/bin/../madpack/madpack.py",
> line 1171, in main
>     _db_upgrade(schema, dbrev)
>   File "/usr/local/greenplum-db-4.3.17/madlib/Versions/1.13/bin/../madpack/madpack.py",
> line 571, in _db_upgrade
>     _db_create_objects(schema, None, True, sc)
>   File "/usr/local/greenplum-db-4.3.17/madlib/Versions/1.13/bin/../madpack/madpack.py",
> line 734, in _db_create_objects
>     raise Exception
> madpack.py: ERROR : MADlib upgrade failed.
> {code}
>
>
>
> --
> This message was sent by Atlassian JIRA
> (v6.4.14#64029)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message